An error occurred while updating .....: Download failed. Forbidden

I am having the same issue as here Plugin Updates - Download failed. Forbidden

I have tried these steps

  1. Deactivate & reactivate the extension in issue on the WP > Plugins > Installed Plugins page
  2. After you get redirected back to the Extensions page activate the API license again
  3. Try to perform updates after this.

The only way to update is to download from the site manually.

I still get the same issue actually unless I reactivate the API license every time before updating.

I just end up downloading the extension manually from the website as it is faster than fooling around with the API keys again.

I ended up removing the keys form my portal and then activating and it worked

I am not sure how many times i reported update issues with extensions in the past. Current issue:

Error Details

An error of type E_ERROR was caused in line 516 of the file /www/htdocs/w01af748/xxxxx/wp-content/plugins/mainwp/class/class-mainwp-system-handler.php. Error message: Uncaught Error: Attempt to modify property “response” on bool in /www/htdocs/w01af748/xxxxx/wp-content/plugins/mainwp/class/class-mainwp-system-handler.php:516
Stack trace:
#0 /www/htdocs/w01af748/xxxxx/wp-includes/class-wp-hook.php(305): MainWP\Dashboard\MainWP_System_Handler->check_update_custom(false)
#1 /www/htdocs/w01af748/xxxxx/wp-includes/plugin.php(189): WP_Hook->apply_filters(false, Array)
#2 /www/htdocs/w01af748/xxxxx/wp-includes/option.php(1945): apply_filters(‘site_transient_…’, false, ‘update_plugins’)
#3 /www/htdocs/w01af748/xxxxx/wp-includes/update.php(293): get_site_transient(‘update_plugins’)
#4 /www/htdocs/w01af748/xxxxx/wp-includes/class-wp-hook.php(301): wp_update_plugins()
#5 /www/htdocs/w01af748/xxxxx/wp-includes/class-wp-hook.php(327): WP_Hook->apply_filters(NULL, Array)
#6 /www/htdocs/w01af748/xxxxx/wp-includes/plugin.php(470): WP_Hook->do_action(Array)
#7 /www/htdocs/w01af748/xxxxx/wp-admin/includes/class-plugin-upgrader.php(371): do_action(‘upgrader_proces…’, Object(Plugin_Upgrader), Array)
#8 /www/htdocs/w01af748/xxxxx/wp-admin/includes/ajax-actions.php(4477): Plugin_Upgrader->bulk_upgrade(Array)
#9 /www/htdocs/w01af748/xxxxx/wp-includes/class-wp-hook.php(303): wp_ajax_update_plugin(’’)
#10 /www/htdocs/w01af748/xxxxx/wp-includes/class-wp-hook.php(327): WP_Hook->apply_filters(’’, Array)
#11 /www/htdocs/w01af748/xxxxx/wp-includes/plugin.php(470): WP_Hook->do_action(Array)
#12 /www/htdocs/w01af748/xxxxx/wp-admin/admin-ajax.php(187): do_action(‘wp_ajax_update-…’)
#13 {main}

WordPress version 5.8.2
Current theme: Twenty Twenty-One (version 1.4)
Current plugin: MainWP Dashboard (version
PHP version 8.0.13

I did this as well before but the next time there was an update I had the same error again.

Hi @mensmaximus,

Have you tried the MainWP beta version that includes PHP 8 compatibility updates?

So after removing all the keys from my account last week and reactivating everything I see an update today for Pro Reports. When I try and update it fails with the same error.

Hi Bogdan,

no i did not try and i will not try, because we talk about updating extensions. there is no single issue with updating plugins on sites running php 8 while the dashboard is running on php 8 as well. The issues are not new to php 8. extensions updates are an issue for a long time.

ps.: i forgot to remind you that extensions updates do not get announced anymore after the update failed. this is a general issue with the way updates are performed for extensions. i mentioned this long time ago

Because extension updates do not work i decided to update all extension manually. I started with ‘MainWP WooCommerce Shortcuts Extension’. On my MainWP Dashboard installations i see Version 4.1.1. In my account on in the my downloads menu it says the extension is version 4.0.1. I downloaded the extension anyway and looked into the file, it says version 4.1.1.

This is really a mess. Updates don’t work. Versions are displayed wrong. I really don’t have the time to download each extension to check which version it is and if i need to update manually because updates do not get announced anymore.

While digging deeper into the code i found the reason why the updates do not get announced anymore after the download failed error occurred. Because the extension get updated! The issue is not the download and update. The issue is the wrong error message. I never checked that before.

Hi Michael,

Thanks for sharing that info.

I will have our dev team check this right away.

If you get a chance, please feel free to send me more details via Private Message so I can forward it to them.

Glad to hear I am not the only one. For me the update feature for MainWP extensions never really worked. Neither did the update notification. So, I ended up checking and downloading everything manually from the MainWP site. Not a very smooth experience…

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.