Attempted clonings are bloating the cloned website's disk space

I’ve been trying to use MainWP Clone to clone one website to another. I have successfully cloned this site before, and recently.

It gets frozen after creating the backup.

I believe this is due to storage space issues between the two sites. However, I’ve noticed that the cloning attempts are bloating the used storage space on the site I’m attempting to clone from. The “Quota” disk space in WHM is now maxed out - presumably from a bunch of cloning backups.

Where do these clone backups live in the file system on the cloned site? Do I need to delete them manually, or is there a “proper” way to do it? Thanks.

Hi Para, thanks for reaching out.

By design the Clone extension should automatically delete the temp backup file that it creates to clone a site. However, if server stalls, and the process fails, the auto-deletion process will fail too.

In this case, it might be best to manually delete files from the ..wp-content/uploads/mainwp/backup/ directory.


Thanks Bogdan. That worked. There were quite a few backup files in there.

It seems I still can’t successfully clone the site. I’ve definitely cloned this site before.

What kind of issue would cause it to become frozen after: “14:43:50 Creating backup on Site XYZ expected size: 71MB (estimated time: 43 seconds)”

I get these errors in the console:



1 Like

Hm, strange about this error, do you get it on any other site or just this one?

@bogdan I’m getting this on 2 new sites.

I just now did a complete wipe of one site in CPanel, recreated it with the same disk quota size as the site to be cloned, did a fresh MaiinWP Child install, sync’ed up… and it still fails with the same errors. I don’t understand why this is happening at this point.

Is there a possible cloning bug in the latest release of MainWP? Is there a way to get more detailed errors?

It seems like the response coming back may be somewhat corrupted?

Using Fiddler, I get this HTTP response when it makes the ajax call to get the size:

(unexpected unicode characters here) {“size”:31548}

(there are weird characters there in front, preventing it from being proper json)

And then in the ajax callback, it fails to resolve a response object:

if ( resp.size ) { // resp is null here

I’m not sure what could be corrupting the response. This is a fresh install and I’ve done cloning before on other servers with the same provider / setup just very recently.

Aaaand now I just accidentally cloned over the site I was trying to clone from, wiping it all out. Great. Good to see it still works for the older site.

This is going to be a make-or-break feature for me to continue subscribing to Pro. Please fix this. I shouldn’t have to debug and modify the code.

Hi @Para, thanks for your updates. I am sorry to hear that you cloned wrong site by accident. However, this shows us that there is no bug in the Clone system and it works, but I still don’t know why it fails for the other site.

For the start, can you please make sure that the PHP Memory Limit and WP Memory Limit are set to at least 256M on the sites that you are cloning and PHP Max Execution time along with cURL Timeout are set to at least 300s

Let me know if that helps.

Strangely, I accidentally fixed this by using MultiPHP Manager to update PHP on my site from 7.3 (inherited) to 7.4 (which broke everything, of course), then reverted back to 7.3.

After this, cloning finally worked. No idea why. Was it some issue between 7.3 inherited and 7.3 installed standalone? Could be.

Btw, I did see that you guys added an actual error message for this error since I lasted posted, so I appreciate that.

1 Like

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.