BackupBuddy stuck on sending to offsite backup (Google)

I have the BackupBuddy extension configured on 60 websites, but I have just one website that doesn’t seem to want to send the backup offsite.

To confirm, it works perfectly fine for the rest, except for this one website. I’ve tried reinstalling MainWP Child as well as BackupBuddy, but the issue remains.

It’s able to create the backup, zip it and then just freezes when trying to send. A snippet of the log file can be found below:

----------- ------- ------- Ping? Waiting for server . . .
03:58:02.86 0.24sec 18.28MB Pong! Server replied.
03:58:05.65 0.32sec 18.24MB Loading fileoptions data instance #29
03:58:05.65 0.32sec 18.28MB Fileoptions load using 0.04 MB of memory.
03:58:05.65 0.32sec 18.28MB Waiting for function send_remote_destination to complete. Started 582.91438698769 seconds ago.
03:58:05.65 0.32sec 18.28MB Warning: The function send_remote_destination is taking an abnormally long time to complete (582.91438698769 seconds). The backup may have failed. If it does not increase in the next few minutes it most likely timed out. See the Status Log for details.
----------- ------- ------- Ping? Waiting for server . . .

This process appears to go on indefinitely.

Any assistance would be great.

By any chance is that website hosted with GoDaddy?

Nah it isn’t hosted with them. I don’t think my issue is hosting related either, as all of my sites are on the same service. I also just migrated to another host this week and tested with the same issue.

I thought it may have been a configuration issue with MainWP, but all appears OK in their diagnostics tool. I may need to log a ticket!

Hi Nathan,

This looks like the BackupBuddy plugin problem to me.
MainWP plugin only triggers backup, everything else is handled by the BackupBuddy plugin itself.
You should try to initiate the backup directly from the child site from the BackupBuddy interface to see if you will get the same error. If yes, you should consult the iThemes support team.


Thanks Bogdan, I’ll try there.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.