Bring back Broken Link Checker

I know this plugin was retired with the security issues and ownership changes in the piece for the child sites, but now that it is being maintained again, it would be nice to have this plugin back or another one to do the same thing. I run the version in the repository on almost all of my sites to resolve issues.

I have made some updates to be compliant with the latest WordPress and jQuery and also to clear the errors with v4.1 and the activation check. Is there a way I can send my changes to update the version stored here for everyone? I am not interested in taking over the plugin long term.


Hi Eric, I’d be interested in trying out this cleaned up version.

I also think there’s a need for this, as knowing the site 404’s some / every links can be helpful in knowing before a client that there are issues to look at!


I have had a little play and I remember why I liked this now, would be great to see this recommissioned and with all remote options available like who to email being defined from MWP.

Literally got my vote.


Sweet, thanks for the link, Eric!

1 Like

@jfa - did you have time to review the plugin and test it?
We will definitely interested as well to put it back to MainWP monthly report.
It adds value to the clients.
Thanks, Fred

1 Like

I’ve tested the version provided by @7thcircle and besides a PHP notice, everything seems fine. I’ll have my partner look over the code for the security aspects, but otherwise, seems to work well.

I’ve tested it on my personal website using v1.11.15, it connects to Child sites, retrieves the data and adds a widget in a Child site’s dashboard. Only thing I haven’t checked is if it adds anything to the Pro Report… but I doubt it does :wink:

I know you didn’t want to keep maintaining it, but that’s the bit I can’t commit on right now

1 Like

I’d love to have this back as well. I got my MainWP after they retired this so I never got to try it.

I have updated this for better compatibility with MainWP 4.1.x and moved it from Dropbox to Github so that changes can be tracked (and if anyone has updates I have missed they can contribute).


I mostly have this working in Main WP but I do keep getting “security errors” when I try to access the dashboard and some settings. Is there any way to use this plugin without an API key from MainWP or is there some setting I need to change (or settings mod) to be able to use this without an API key? Thx.

This plugin does require an API key to use it.

As a long time user, I can say that the Pro lifetime license was a great purchase.

1 Like

Yeah I have only been using Main WP for about a week (still testing) although we did buy a Pro license for all the features. We love it so far even though for some reason my profile isn’t showing “Pro.” I’m pretty sure I already know the answer to this Eric but is there any way to get an API key for this plugin since I didn’t have one before it was removed? I really want to use this plugin but I can’t see any way around the API thing when means I can’t really us this plugin. BTW - thanks for your work getting this up on Github. :slight_smile:

Sorry to be a total NOOB here but while I have connected sites with Link Checker and the data generally shows on the Main WP Overview page (MainWP Broken Links Checker...) but when I try to go to settings or click the dashboard link I get a security error like this - WordPress › Error - Google ... and it says “Sorry, you are not allowed to access this page.” I asked Main WP Support about this and they said I didn’t need an API key but I think without the API I will continue to get this error. Is there any workaround for this? Thanks.

The error could be as simple as a cache issue on your site. It could also be a permissions issue. I am not seeing the error on my site. I am using php 7.4 and not 8 in case that makes a difference and I have no caching on my dashboard.

1 Like

Ok thanks for the reply. I’ll keep troubleshooting. I am on PHP 7.4.27 on CloudLinux on a dedicated server. I would say this is a caching issue but I don’t have WP Rocket installed on this site. LS cache is enabled on our server but not for this site. Odd. Not sure how to fix the permissions issue (perhaps a folder problem - I’ll look into that) as all of the other extensions work fine. I’m like 50% of the way there as sites are connected and synching but I am just having these odd errors. Thanks again.

Hey Eric - what version of the Main WP Plugin are you using (is it the latest one)? I ask because according to Support (and keeping in mind they don’t really support this plugin now):

“The problem is that API key won’t solve this “security” error that shows.
For some reason, it looks like that version of the extension is just not fully compatible with the latest MainWP Dashboard version.”

So, not sure what to do next here as all I did was upload the plugin from the main WordPress dashboard screen and activate it. Any additional thoughts are welcome. Best.

I have the current version of the dashboard plugin running 4.1.11

the only security plugins are Patchstack (Patchstack – WordPress & Plugins Security – WordPress plugin | and WP 2FA (WP 2FA – Two-factor authentication for WordPress – WordPress plugin | as all of my security is server level and Cloudflare

1 Like

Yeah that is the same version I am on Eric. We are on a dedicated server and this is a unique account and I don’t have this on our Sucuri firewall yet although I will have that done shortly. So, this has to be something to do with WordPress security or possibly even the API key thing that they say shouldn’t matter.

I have also checked file permissions for this plugin directory and those seem correct so not sure what else to check but I really appreciate your assistance since I know this is not something you created. I assume you have an API key in your account so I still suspect that is still the issue.

Is there any way to bypass that API key check (I see you did some work on this about a year ago to clear API check errors). It is also possible that something didn’t 100% complete in WP activation without the API key as I believe it forwards right to the Main WP dash right after you activate the plugin.

I may escalate this to our hosting support to see if they have any other ideas as they are really good with WordPress issues.

Thanks again.

My site is behind Cloudflare on GridPane hosting and has been running for ages with no issues even when I was on shared hosting. I run nginx with a custom WAF but the error you are seeing is role related most likely. Have you tried a new user created as an admin? Are you using MainWP Team control?