Cannot add site - HTTP error - SSL certificate problem: unable to get local issuer certificate

I upgraded our Windows WordPress server to use PHP 7.4 and now it is not letting me add a new site to my MainWP dashboard.

This may be a coincidence but I was able to add sites before and have a number of sites connected.

The MainWP child plugin is not reporting any errors and shows a Pass on SSL Extension Enabled and SSL Warnings.

The MainWP server status is not showing any errors.

The Connection Test succeeds without any errors.

It just fails when I try to add the site.

Any suggestions?


Hi @Charlotte,

Can you please post the community system report from your MainWP Dashboard for review? The report is located in your Dashboard under Status → Server, on the top right of the page.

Be sure to use the button like the one below; this button hides all your private information:


Pressing the button auto-copies the report to your clipboard then just paste it in a reply here.

I tried changing the PHP version back to 7.3.24 but with no change. Thanks

Server Info Required Detected Status

MainWP Dashboard
MainWP Dashboard Version Pass
MainWP Upload Directory Writable Writable Pass
MainWP Extensions
MainWP Maintenance Extension API License Active Pass
WordPress Version >=3.6 5.5.3 Pass
WordPress Memory Limit >=64M 1024M Pass
MultiSite Disabled =true true Pass
FileSystem Method = direct direct Pass
PHP Version >=5.6 7.3.24 Pass
PHP Safe Mode Disabled =true true Pass
PHP Max Execution Time >=30 seconds 300 Pass
PHP Max Input Time >=30 seconds 60 Pass
PHP Memory Limit >=128M 1024M Pass
PCRE Backtracking Limit >=10000 1000000 Pass
PHP Upload Max Filesize >=2M 1024M Pass
PHP Post Max Size >=2M 1024M Pass
SSL Extension Enabled =true true Pass
SSL Warnings = empty Pass
cURL Extension Enabled =true true Pass
cURL Timeout >=300 seconds 300 Pass
cURL Version >=7.18.1 7.70.0 Pass
cURL SSL Version >=OpenSSL/0.9.8l OpenSSL/1.1.1g Pass
PHP Allow URL fopen YES
PHP Exif Support YES ( V7.3.)
PHP Disabled Functions No functions disabled.
PHP Loaded Extensions Core, PDO, Phar, Reflection, SPL, SimpleXML, Zend OPcache, bcmath, bz2, calendar, cgi-fcgi, ctype, curl, date, dom, exif, fileinfo, filter, ftp, gd, gettext, hash, iconv, imagick, imap, json, ldap, libxml, mbstring, mysqli, mysqlnd, openssl, pcre, pdo_mysql, pdo_sqlite, readline, session, soap, standard, tidy, tokenizer, wddx, xml, xmlreader, xmlrpc, xmlwriter, zip, zlib
MySQL Version >=5.0 10.1.10-MariaDB Pass
MySQL Client Encoding utf8
Server Info
Server Software Microsoft-IIS/8.5
Operating System WINNT
Architecture 64 bit
Server Protocol HTTP/1.1
Server self connect Response Test O.K.
User Agent Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/87.0.4280.67 Safari/537.36 Edg/87.0.664.47
Gateway Interface CGI/1.1
Memory Usage 14.16 MB
Request Time 1606588671
Accept Content text/html,application/xhtml+xml,application/xml;q=0.9,image/webp,image/apng,/;q=0.8,application/signed-exchange;v=b3;q=0.9
Accept-Charset Content N/A
MainWP Settings
Number Of Child Sites 9
Use WP-Cron Yes
Optimize for Shared Hosting or Big NetworksNo
Automatic Daily Update Install trusted updates
Abandoned Plugins/Themes Tolerance 365
Maximum number of posts to return 50
Maximum number of pages to return 50
Primary Backup System Default MainWP Backups
Maximum simultaneous requests 4
Minimum delay between requests 200
Maximum simultaneous requests per ip1
Minimum delay between requests to the same ip1000
Maximum simultaneous sync requests 8
Minimum simultaneous install/update requests3
Active Plugins
MainWP Child 4.1.2 Inactive
MainWP Dashboard Active
Simple History 2.37.2 Active
Wordfence Security 7.4.12 Active

Hi, thanks for getting back to me.

I reviewed the report and couldn’t see anything unusual.

Would you mind opening a private Help Desk ticket so we can collect some additional information & investigate further?

Thanks. I have done that.

I had this problem last week with IIS based install too

Check using PHPInfo that your PHP is where it’s supposed to be for OpenSSL to find it.

Will dig out the two fixes I needed to resolve this. I was using PHP7.4 on IIS10 and had this issue.

Hi Stuart,

That would be great!

That is the configuration I am using except for IIS 8 instead of 10.

When I switched from PHP 7.3 to 7.4 the location of the openssl.cnf switched from
C:\usr\local\ssl/openssl.cnf to C:\Program Files\Common Files\SSL/openssl.cnf

I was getting an error on SSL in the client status until I copied the “openssl.cnf” file to the new location.
Now I am not getting any errors in either but it still won’t add a new site.


Next to your openssl.cng in the common files\SSL folder do you also have a file called cacert.pem?

If not grab a copy and stick it in the same folder.

Kind Regards,


Hi Stuart,

Thanks for the suggestion. It is still not working. But I am running on Windows Server 2012 R2 and IIS version 8.5. so perhaps that is part of the issue.

I am going to upgrade the server over our Christmas break and maybe that will resolve it.

thanks again for the help!


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.