Cannot Connect mainWP Clients

All sites are on the same server. (Windows 2019 using IIS and latest version of WP 5.3.2)
MainWP Dashboard and MainWP Child are the latest versions available in the Plugins of WP currently.

Have tried installing the MainWP plugin both as a LocalHost and as a WebHost, makes no difference.

When I try and connect a client site (they have the MainWP Client installed) I get a “Invalid+request%21” message. This occurs from the setup wizard or from the main page Sites/Add New.

The CLIENTS all have WordFence installed, but if I deactivate WordFence I still get the same error message specified above.

The TEST CONNECTION button finds the child sites no problem. The issue is when trying to CONNECT the child site into the mainWP.

Oh… and I AM using the Security ID on the clients and entering it into the MainWP page when trying to connect them. Also is an SSL connection using the Let’s Encrypt TLS1.2 option from the drop down.

Also just tried with disabling SSL and connecting via HTTP instead… no difference same error message listed above

Any assistance would be greatly appreciated.

Hi @rstrumbel, can you check the MainWP > Server Information page on your MainWP Dashboard and check under the SSL Warnings row. Do you have this error there: error:02001002:system library:fopen:No such file or directory?

There is a different error there:
error:02001003:system library:fopen:No such process

That is with it setup as a WebHost.

If I switch over to a LocalHost and specify the location of my openssl.cnf… that error changes to:
error:2006D080:BIO routines:BIO_new_file:no such file

But I know for certain I have the correct path entered.
PHPINFO returns the wrong path as c:/usr/local/ssl/openssl.cnf, the correct path is C:\PHP\7.3.8\extras\ssl (which is what I entered).

The only other warnings on the Server Information page are:
cURL Timeout >=300 seconds… mine is set to 60
WordPress Memory Limit >=64M… mine is set to 40M

Everything else is green

I got it figured out.
When specifying the openssl.cnf path, you need to include the openssl.cnf filename in the path you type in.
I had assumed it just needed the path and not the filename.
Added in the filename as well and it’s up and running!



Hey @rstrumbel, great glad to see that the problem is solved. I was just about to post how to fix this problem, but you got it handled.

For just in case other users stumble upon the same issue, I will leave steps how to fix it:

  1. Go to your MainWP Dashboard
  2. Go to the MainWP > Settings > MainWP Tools page and click the Quick Setup Wizard button
  3. When the setup starts, proceed to the first step and select Localhost > Windows
    ​4. The new option will appear where you can add the openssl.cnf file path (see here how to find the file)
  4. Proceed to the next step and feel free to skip the rest of the Quick Setup wizard.

Once you get back to the MainWP Dashboard > Status page, check if the SSL Warning is gone.


This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.