Cannot import sites - page just hangs

Any help appreciated with importing sites. Our team has hit a snag with this and we’ve spent several hours banging our heads against the wall. And in the process looks like we’ve annoyed the support team unfortunately.

The page just hangs and no errors are returned which makes me think it could be a hosting issue or something specifically with mainwp that is incompatible with our host.

This is the format of our csv file:”,“”,“admin”,"","","","",“0”,“0”

Image here:

Also made sure to uncheck header as we removed it. We also tried to keep it and checked the toggle as required. And we tried to enter in optional values but nothing worked. It just kept hanging.

I’d “buy” someone a beer or coffee to help us out. We’ve ran out of options.

Thank you!


### Server Info                    Required                                               Detected                                     Status   ###

MainWP Dashboard                   
MainWP Dashboard Version           4.1.7                                                  4.1.7                                        Pass        
MainWP Upload Directory            Writable                                               Writable                                     Pass        
MainWP Extensions                  
Boilerplate Extension                                                    API License Active                           Pass        
MainWP Article Uploader Extension                                                API License Active                           Pass        
MainWP Bulk Settings Manager Extension4.0.2.1                                                API License Active                           Pass        
MainWP Clone Extension             4.0.1                                                  API License Active                           Pass        
MainWP Matomo Extension            4.0.3                                                  API License Active                           Pass        
MainWP Post Dripper Extension      4.0.3                                                  API License Active                           Pass        
MainWP Virusdie Extension          4.0.0-beta3                                            API License Active                           Pass        
WordPress Version                  >=3.6                                                  5.8                                          Pass        
WordPress Memory Limit             >=64M                                                  40M                                          Warning     
MultiSite Disabled                 =true                                                  true                                         Pass        
FileSystem Method                  = direct                                               direct                                       Pass        
PHP Version                        >=5.6                                                  7.4.21                                       Pass        
PHP Safe Mode Disabled             =true                                                  true                                         Pass        
PHP Max Execution Time             >=30 seconds                                           120                                          Pass        
PHP Max Input Time                 >=30 seconds                                           120                                          Pass        
PHP Memory Limit                   >=128M                                                 768M                                         Pass        
PCRE Backtracking Limit            >=10000                                                1000000                                      Pass        
PHP Upload Max Filesize            >=2M                                                   256M                                         Pass        
PHP Post Max Size                  >=2M                                                   256M                                         Pass        
SSL Extension Enabled              =true                                                  true                                         Pass        
SSL Warnings                       = empty                                                                                             Pass        
cURL Extension Enabled             =true                                                  true                                         Pass        
cURL Timeout                       >=300 seconds                                          40                                           Warning     
cURL Version                       >=7.18.1                                               7.66.0                                       Pass        
cURL SSL Version                   >=OpenSSL/0.9.8l                                       OpenSSL/1.1.1k-fips                          Pass        
PHP Allow URL fopen                YES                                                    
PHP Exif Support                   YES ( V7.4.)                                           
PHP IPTC Support                   YES                                                    
PHP XML Support                    YES                                                    
PHP Disabled Functions             No functions disabled.                                 
PHP Loaded Extensions              Core, PDO, Phar, Reflection, SPL, SimpleXML, Zend OPcache, apache2handler, bcmath, bz2, calendar, ctype, curl, date, dba, dom, enchant, exif, fileinfo, filter, ftp, gd, gettext, gmp, hash, iconv, imap, intl, ionCube Loader, json, libxml, mbstring, memcached, mysqli, mysqlnd, openssl, pcre, pdo_mysql, pdo_pgsql, pdo_sqlite, pgsql, posix, pspell, session, shmop, soap, sockets, sodium, sqlite3, standard, sysvmsg, sysvsem, tidy, tokenizer, xml, xmlreader, xmlrpc, xmlwriter, xsl, zip, zlib
MySQL Version                      >=5.0                                                  5.7.32-35-log                                Pass        
MySQL Mode                         NO_ENGINE_SUBSTITUTION                                 
MySQL Client Encoding              utf8                                                   
Server Info                        
Server Software                    Apache                                                 
Operating System                   Linux                                                  
Architecture                       64		 bit                                               
Server Protocol                    HTTP/1.0                                               
HTTPS                              ON                                                     
Server self connect                Response Test O.K.                                     
User Agent                         Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_7) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/91.0.4472.164 Safari/537.36
Gateway Interface                  CGI/1.1                                                
Memory Usage                       5.57 MB                                                
Request Time                       1627410785                                             
Accept Content                     text/html,application/xhtml+xml,application/xml;q=0.9,image/avif,image/webp,image/apng,*/*;q=0.8,application/signed-exchange;v=b3;q=0.9
Accept-Charset Content             N/A                                                    
MainWP Settings                    
Number Of Child Sites              11                                                     
Use WP-Cron                        No                                                     
Optimize for Shared Hosting or Big NetworksNo                                                     
Automatic Daily Update             Install trusted updates                                
Abandoned Plugins/Themes Tolerance                                                        
Maximum number of posts to return  50                                                     
Maximum number of pages to return                                                         
Primary Backup System              Default MainWP Backups                                 
Maximum simultaneous requests      4                                                      
Minimum delay between requests     200                                                    
Maximum simultaneous requests per ip1                                                      
Minimum delay between requests to the same ip1000                                                   
Maximum simultaneous sync requests                                                        
Minimum simultaneous install/update requests                                                       
Active Plugins                     
Gutenberg Blocks and Template Library by Otter1.6.9                                                  Active                                       
MainWP Dashboard                   4.1.7                                                  Active                                       
SG Security                        1.0.4                                                  Inactive                                     
SiteGround Optimizer               5.8.2                                                  Inactive                                     
WordPress Importer                 0.7                                                    Inactive                                     
WordPress Starter                  1.1.7                                                  Inactive                                     
WPForms Lite                                                             Inactive                                     

Hi @mzen,

Thanks for reaching out.

First, let me assure you that no one in the team got annoyed, we are always giving out best to help.

I think that the main problem here is incorrect formatting.

Can you try to list the sites without of quote marks, like:,, admin,,,,,0,auto,, admin,,,,,0,auto

Like in the example file that is available in the Import Sites Page

# The header fields may not be renamed
# Url and Admin Name are the only required columns
# Possible values for Verify Certificate: 1 or 0 (1 for true, 0 for false)
# Possible values for SSL Version: auto, 1.x, 1, 2, 1.1, 1.2, 1.3. The default value is "auto"
Site Name, Url, Admin Name, Group,Security ID,HTTP Username,HTTP Password,Verify Certificate,SSL Version
Site 1,,Admin,Group Name,Security ID,Username,Password,1,auto
Site 2,,Admin,Group Name,Security ID,Username,Password,0,auto
Site 3,,Admin,Group Name,Security ID,,,T,1.x
Site 4,,Admin,Group Name,Security ID,Username,Password,1,auto
Site 5,,Admin,Group Name,Security ID,Username,Password,0,1.3

In columns where there is nothing to use (for example HTTP Username and HTTP password) you just leave it empty.

Let me know how that goes.


Thanks for the reply. I feel bad with my several tickets over the past days. I know how it is as I have been on that side of the fence many times :slight_smile:

Anyways, we have tried with quotes and no quotes. As mentioned we’re seriously pulling our hair out here. It’s no joke we have tried everything.

We tried the quotes because I saw this post here after searching the forums:

But alas, still no luck.

Anyone up for the challenge of helping me to get the import working?

I can offer $50 for anyone to solve this and provide a reason or fix to this issue.

Thank you.

@mzen I believe that I have figured out what the issue is. Please review your MainWP Ticket as there is private data attached to it. I will paste an example below for others.

When EXPORTING via the MainWP Tools > Export feature you get this syntax. ( SYNTAX IS EXTREMLEY IMPORTANT WHEN DEALING WITH CSV FILES. )

Changes made are as follows:
1.) Notice the Headers ( They are case/space sensitive )
2.) Added Quotes “”
3.) Changed “0” to “1” for check SSL
4.) Changed “Auto” to “0”
5.) Made all URL’s lowercase
6.) added a forward slash to the end of the URL

site name,url,admin name,group,security id,http username,http password,verify certificate,ssl version”,“",“admin_username”,"","","","",“1”,"0

Double check that Quotes are actually Quotes

A few failed - but they may just need to be Deactivated & reactivated.

1 Like

I’ll take a $50 gratuity! :wink: PayPal.Me <---- just kidding unless you feel compelled.

It’s most likely syntax. though. Check the Export Tool syntax located @ MainWP Settings > MainWP Tools

I have responded to this thread with the correct syntax.

Well I’m a man of my word :wink: however, I just replied back to the private ticket because unfortunately all 12 sites failed on import.

We’re almost there after dozens of attempts so it’s really great to see the process not hang.

But still frustrating to see all sites failed on import. Any additional help is appreciated.

1 Like

@mzen Yeah the only thing I can say is they need to be deactivated and reactivated…

You may try my Child Plugin Reset Tool to clear the child sites DB out and start fresh. There may be stuff stuck from all the testing. Bitbucket

Click Download on the left side menu ( DELETE PLUGIN AFTER FOR SECURITY )

1 Like

@kwcjr Finally working!

I can only imagine how many issues you previously encountered to figure out this fix! Monumental thanks to you. I am genuinely compelled :beers:


@mzen Fanfrikentasktic!!! So glad it’s working for you now and thank you very much for the compliments!

Yeah, we are now aware that this isn’t as straight forward as it should be & will be working in the near future to make this process a bit more smoother and less confusing.

Thanks a bunch for your extreme patience - it’s refreshing!


This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.