Can't connect a single site

Hi! I have been eyeing MainWP for a while and am now ready to jump ship, coming from ManageWp. I have about 25/30 sites that I maintain and more coming.
I wanted to start with the free version to just try out before buying pro and going all in, but I can’t seem to be able to connect a single site.
Everytime I try to connect I get “Invalid request%21” even though the Test Connection gives no errors. I have not much knowledge of MainWP yet, as I just started using it and don’t know how to figure out what is going wrong.

Hi @digitalie,
Do you have firewall on the site you want to connect? If yes, disable it temporarily, connect and put it back on. Sometime we see some issues like that with WordFence.

I’ve never had an issue with Wordfence (hundreds of sites). If you do, then it must be a setting that’s too strict. The default settings don’t block the connection.

Hi @digitalie, I believe that you have a helpdesk ticket in that I replied a few minutes ago, but I will answer here also:

This problem comes from the OpenSSL library on your localhost.

The error:02001003:system library:fopen:No such process SSL means that the OpenSSL is not configured properly. You can see it if you check the SSL Warnings check on the MainWP > Status page.

To fix this, please try the following:

  1. Go to your MainWP Dashboard
  2. Go to the MainWP > Settings > MainWP Tools page and click the Quick Setup Wizard button
  3. When the setup starts, proceed to the first step and select Localhost > Windows
  4. The new option will appear where you can add the openssl.cnf file path (see here how to find the file)
  5. Proceed to the next step and feel free to skip the rest of the Quick Setup wizard.

Once you get back to the MainWP Dashboard > Status page, check if the SSL Warning is gone. If yes, you should be able to connect sites.

This is something similar as this problem here.

[EDIT] Confirmed via support ticket that this solved the problem.

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.