Changing PHP version from 7.4 to 8.0 or 8.1 makes connection no longer work

I’m running a few servers on Hetzner together with Runcloud as my control panel.

I’m in the process of upgrading some web apps from 7.4 to 8.0 - and when that’s done - my MainWP connection to those sites no longer works.

I get the error:
Public key already set. Please deactivate & reactivate the MainWP Child plugin on the child site and try again.

Obviously, I tried that but that does not fix anything. There is nothing really in my web app log files that seem to be related to MainWP.

Does someone have a clue why this could be a thing or has/had similar experiences?

Just in case this helps, I’m adding my server info from the MainWP Dashboard:


WordPress Check Required Detected Status

FileSystem Method = direct direct Pass
MultiSite Disabled =true true Pass
WordPress Memory Limit >=64M 40M Warning
WordPress Version >=3.6 6.0.1 Pass

PHP Required Detected Status

cURL Extension Enabled =true true Pass
cURL SSL Version >=OpenSSL/1.1.0 OpenSSL/1.1.1f Pass
cURL Timeout >=300 seconds 60 Warning
cURL Version >=7.29.0 7.68.0 Pass
PCRE Backtracking Limit >=10000 1000000 Pass
PHP Allow URL fopen N/A YES
PHP Disabled Functions N/A _getppid, diskfreespace, dl, escapeshellcmd, exec, fpassthru, getmyuid, highlight_file, ignore_user_abort, ini_alter, ini_alter, leak, link, listen, passthru, pcntl_exec, popen, posix, posix_ctermid, posix_getcwd, posix_getegid, posix_geteuid, posix_geteuid, posix_getgid, posix_getgrgid, posix_getgrnam, posix_getgroups, posix_getlogin, posix_getpgid, posix_getpgrp, posix_getpid, posix_getpwuid, posix_getrlimit, posix_getsid, posix_getuid, posix_isatty, posix_kill, posix_mkfifo, posix_setegid, posix_seteuid, posix_setgid, posix_setpgid, posix_setsid, posix_setuid, posix_times, posix_ttyname, posix_uname, proc_close, proc_nice, proc_open, proc_terminate, set_time_limit, shell_exec, show_source, socket_accept, socket_bind, socket_clear_error, socket_close, socket_connect, socket_create_listen, socket_create_pair, socket_listen, socket_read, source, stream_socket_server, symlink, system, tmpfile, virtual,
PHP Exif Support N/A YES ( V8.0.)
PHP Loaded Extensions N/A Core, FFI, PDO, Phar, Reflection, SPL, SimpleXML, Zend OPcache, bcmath, bz2, calendar, cgi-fcgi, ctype, curl, date, dom, enchant, exif, fileinfo, filter, ftp, gd, gettext, gmp, hash, iconv, igbinary, imap, intl, json, libxml, mbstring, memcache, memcached, msgpack, mysqli, mysqlnd, openssl, pcntl, pcre, pdo_mysql, pdo_sqlite, posix, pspell, readline, realpath_turbo, redis, session, shmop, soap, sockets, sodium, sqlite3, standard, swoole, sysvmsg, sysvsem, sysvshm, tidy, tokenizer, xml, xmlreader, xmlrpc, xmlwriter, xsl, zip, zlib
PHP Max Execution Time >=30 seconds 60 Pass
PHP Max Input Time >=30 seconds 120 Pass
PHP Memory Limit >=128M 512M Pass
PHP Post Max Size >=2M 256M Pass
PHP Safe Mode Disabled =true true Pass
PHP Upload Max Filesize >=2M 256M Pass
PHP Version >=7.0 8.0.21 Pass
SSL Extension Enabled =true true Pass
SSL Warnings = empty Pass

MySQL Required Detected Status

MySQL Client Encoding N/A utf8mb4
MySQL Version >=5.0 10.5.17-MariaDB-1:10.5.17+maria~ubu2004 Pass

Server Configuration Detected Value

Accept Content text/html,application/xhtml+xml,application/xml;q=0.9,image/avif,image/webp,/;q=0.8
Accept-Charset Content N/A
Architecture 64 bit
Gateway Interface CGI/1.1
Memory Usage 38.44 MB
Operating System Linux
Request Time 1660760516
Server Protocol HTTP/1.0
Server self connect Not expected HTTP response body:
Server Software Apache/2.4.54 (Unix) OpenSSL/1.1.1f
User Agent Mozilla/5.0 (Macintosh; Intel Mac OS X 10.15; rv:103.0) Gecko/20100101 Firefox/103.0

MainWP Dashboard Settings Detected Value

Abandoned plugins/themes tolerance 365
Basic uptime monitoring enabled No
Cache control enabled No
MainWP Dashboard Version Latest: 4.2.7 | Detected: 4.2.7 Pass
MainWP legacy backups enabled No
Maximum number of pages to return
Maximum number of posts to return
Maximum simultaneous install and update requests3
Maximum simultaneous requests 4
Maximum simultaneous requests per ip1
Maximum simultaneous sync requests 8
Minimum delay between requests 200
Minimum delay between requests to the same ip1000
Number of child sites 49
Optimize for shared hosting or big networksYes
Plugin advanced automatic updates enabledNo
Primary backup system MainWP Legacy Backups
REST API enabled No
Site health monitoring enabled No
Theme advanced automatic updates enabledNo
Use WP Cron Yes
WP Core advanced automatic updates enabledNo

Extensions Version License Status

MainWP Clean and Lock Extension Deactivated Warning

Plugin Version Status

MainWP Dashboard 4.2.7 Active

1 Like

I was able to find out that, when the web app stack type is set to “WordPress” - it does work. When I originally created the web apps on the server, I chose “custom” as I didn’t need a blank/new WP to install. Turns out Runcloud configs might change stuff based of this setting - so I’m reaching out to RunCloud now.


Hey @jeroenrotty

Thank you for updating us, and I’m glad you managed to isolate the issue.

1 Like

Thanks! However, I hope that MainWP can improve this error messaging to be more clear about what is happening because it really isn’t due to anything related to the key that is set … Room for improvement if you ask me.

1 Like