Does the Wordfence Extension work for anyone?

I’m having problems with the Wordfence extension since the beginning. I wonder if it is just me or do others have the same issues. For instance: In the child sites overview table there is an indicator that once showed if there are problems. Nowadays this is only a gray icon with no function.

In the extensions overview table though many icons show a red symbol but whenever I click on them there are NO Wordfence issues shown.

The results table is always empty:

I used to like it but it had it’s problems in the beginning already. I guess mainly because Wordfence changed a lot in the past. I hope these issues can be fixed. Thanks for reading :slight_smile:

@phalancs Thank you for reporting this.

When you reach the Security Scan page can you try to refresh the page immediately and let me know if the Data appears or not?

I seem to be having a similar issue here. On the Wordfence Dashboard tab I get a red status shield for my website. When I click on the shield all the scan stages show grey / icons. How can I see the issues related to the scan results? In Wordfence Central the scans displays correctly. I really want to be able to use this Extension instead of Wordfence Central, is it sometihng I am doing wrong or is the Wordfence Extension just buggy?

Also, now in the Wordfence Dashboard I select all the child sites then click the “Scan all Child Sites” green button and get an error saying “Please select websites to scan” even though the sites are selected… Thought?

The extension simply does not work. And I have several issues open. It should be discontinued until fixed or be removed permanently. I have the same problems as you mentioned.

We got the extension fixed and working on the release. I will update this topic as soon as the new version is out.

1 Like

The new version (4.0.1) is released

1 Like

Hmm, the icons in the sites overview table are still gray and individual site scans still fail to start. The according button in the menu with the three dots has no function. The bulk actipons menu now lacks the start scan option. Furthermore still no results are shown in the results table. The “ignored results” table works though (but i am not quite sure if this worked before).

Grey icons in the overview:


Empty results page:

No function on the start scan button

Update: In some cases results ARE shown. It is this at least this type of error that is never reflected on the child sites results overview page though:

Type: Skipped Paths

  • 5 paths were skipped for the malware scan due to scan settings

Hi @phalancs, thanks for the feedback. However, I am not able to duplicate any of the reported issues.

Status Column shows correct icons:

In the Sites table:

Scan Results show correctly:

Actions menu works properly for me (in this example, I triggered a new scan):

Can you please try to clear all cache, and maybe try to deactivate non-MainWP plugins temporarily to see if there is some conflict on your setup. If non of this helps, I would really like our dev team to check this further, please feel free to open a helpdesk ticket so we can check this further.

1 Like