Google Analytics disconnect evry 3 days

Hello. Enty 3-5 days I get this error. And I have to enter the codes again. Any thoughts?

An error occured: { “error”: { “code”: 401, “message”: "Request is missing required authentication credential. Expected OAuth 2 access token, login cookie or other valid authentication credential. See", “errors”: [ { “message”: “Login Required.”, “domain”: “global”, “reason”: “required”, “location”: “Authorization”, “locationType”: “header” } ], “status”: “UNAUTHENTICATED” } }
Please check your settings, try reconnecting to your Google Analytics account in the settings.

Hi there,

the error message 401 indicates that there is some authentication problem on the GA API side.

Have you tried to create a new set of API credentials and re-authenticate your account in the extension?

I’ve had this same issue. I’ll try creating a second set of API credentials as well.

1 Like

Let us know how it goes.

HI Bogdan,

It looks like our site has once again lost connectivity, even after creating and using new credentials.

Same here. Lost connectivity even after creating and using new credentials.

I believe that the problem comes from the GA API side.
Do you still get the 401 error?

yes. and the Google support says it’s not their problem.

Since it’s a security layer on their side, they should at least tell you what triggers it. Can you ask them for more details?

Unfortunately they can not tell me. I insisted a lot and they told me they did not know.

Hi, not sure if this has been resolved outside of the thread, but unfortunately I’m getting the same error.

I am sorry to hear that. But not sure what else can be done.

Just to be sure that we are missing something, would you mind opening a private Help Desk ticket so we can collect some additional information & investigate further?

@joshcoxjcs Please open a separate ticket for your issue so that we may help you separate from this thread. Thanks for your understanding.

Thanks @kwcjr and @bogdan, have just created a ticket.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

The app I set up in Google Analytics was in the testing mode instead of published, they didn’t make it obvious but in testing mode, the authentication is revoked after a few days. I switched my app to published, and it has been working so far.

1 Like