Import Sites Doesn't Work

I’ve read every community post on importing sites not working and I have to say I’m pretty frustrated. I’ve tried all the things and the dashboard just hangs at importing sites. Not even an error message!

How can importing a CSV file be so complex!?!

I have:

  • Downloaded fresh template
  • Checked syntax and made sure everything was lowercase
  • No quotations, only commas
  • Only using site name / url / admin name fields, everything else blank
  • Made sure file is csv, not text or xls
  • have tried with headers and without

What magic is required to get MainWP to recognize this csv file!?!

I may have just discovered the issue:

The downloadable import template does NOT use quotes.
Site 1,http://site1.com,Admin,Group Name,Security ID,Username,Password,1,auto

The file generated when exporting existing sites DOES use quotes.
“3CM Stone”,“https://www.3cmstone.com/",“JastMedia”,"","","","",“0”,"0

What’s the correct format MainWP?

Do I really have to put quotes around everything?

Hi Darren,

You should not use quotes.

If you check the sample CSV file provided on the Import Sites page, you will see the correct format.

Here is an example:

Site 1,http://site1.com,Admin,Group Name,Security ID,Username,Password,1,auto
Site 2,http://site2.com,Admin,Group Name,Security ID,Username,Password,0,auto
Site 3,http://site3.com,Admin,Group Name,Security ID,,,T,1.x
Site 4,http://site4.com,Admin,Group Name,Security ID,Username,Password,1,auto
Site 5,http://site5.com,Admin,Group Name,Security ID,Username,Password,0,1.3

I was able to get them to import finally. A couple of notes:

  • The export sites CSV uses quotes. Why? If I’m going to modify, move, or reimport I have to remove them all.

  • I believe the problem I was experiencing was because MacOS Excel and TextEdit are not creating the CSV files in a format MainWP likes. I downloaded Xtabulator for Mac and opened/saved the same import file which failed and it was imported perfectly.

Hi Darren,

Thanks for verifying that the problem has been resolved.

Regarding the Usability problems you reported, I will have our dev team check this.

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.

The problem should be permanently fixed in the MainWP Dashboard 4.1.11 where the import process accepts both CSV versions with or without quotemarks.

1 Like