Installing from favourite plugins error

I was trying to install some fav plugins to various sites but all errored: ‘Installation failed: Forbidden’

Installing the same plug through the normal install (from repository) works fine, installing the same fav plugin zip file direct at site level is fine and even installing the same zip file though the default ‘upload then install’ works perfectly.

So, only through the fav plugin install option it errors.

Please advise

The ‘upload then install’ Says it completed …but looking at the site it actually hasn’t!!

Is your MainWP dashboard running on a local environment? Then the child sites can’t download the zip from your dashboard.
If not, there might be a firewall/security issue that’s blocking the download.

We couldn’t reproduce this on our test Dashboard, and furthermore, the dialog for installing Favorite plugins looks different from the one you provided.

From which page are you trying to install the plugin?
Please provide screenshots and detailed descriptions.

And have a look at @josklever post as well. A security rule can block the download, and if it is a localhost, then it cannot work.

I have the same Issue,
Interested to see if any fix yet?
Trying to upload wp activity log,
Uploaded the plug in to favourites got the installation failed forbidden

tried installing with upload .zip file function said it uploaded but when I went to site it did not load plugin to the site.

if I search for the plug in then click install the Plug in, it installs fine

I am on griidpane tried deactivating 7WAF firewall, same issue

Any Help appreciated


Hi @Ebundant-Online

Can you please elaborate on this please?
Did you manage to add the WP Activity Log to Favorites without a problem? Did you do it from the Extensions > Favorites page, or from the Plugins > Install plugins page?

And please try temporarily deactivating any security rules you may have on the child site (plugins, server firewalls, .htaccess rules), and also temporarily disable cloud proxies such as Cloudflare and see if that helps.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.