Invalid request%21

I am a new user trying to connect to a child site and get the above error. I have looked at other questions and followed onscreen instructions to find the OpenSSL.cnf.

This location - C:\usr\local\ssl/openssl.cnf doesn’t seem to exist on my computer, it doesn’t even look like a windows path. I tried putting into the setup but to no effect. Please help me to put the correct path into the setup window.

I am using Flywheel local as the local host.

Hi David, can you try to locate the file by using the Search feature in File Explorer on your computer?

Yes, I have tried that but nothing is found.

I have some other websites in the local host that do work. In fact MainWP works but will not connect to any of my websites.

OK, I’ve fixed it (I think).
After I installed the updraftplus plugin I found it at

C:\Users\david\Local Sites\mainwp\app\public\wp-content\plugins\updraftplus\vendor\phpseclib\phpseclib\phpseclib\openssl.cnf

What a path!

Anyone using Local (by Flywheel) as their local server will run into the “Invalid+request%21” when adding sites because MainWP is hardwired with a path to openssl.cnf. The easiest fix is to figure out the path your local server is looking for openssl.cnf and add an empty iconssl.cnf file there. In my case I used the WP-ServerInfo Wordpress plugin which has the path in the php info screen (phpinfo) in the OpenSSL section.
Open /wp-content/plugins/mainwp/pages/page-mainwp-setup-wizard.php add the path there and save it.
Here’s the empty iconssl.cnf file I created:

HOME			= .

[ v3_ca ]

This issue could be easily avoided if MainWP hardwired the path to an empty openssl.cnf file in the mainwp plugin includes and avoid this issue for the next person that runs into it - it’s a really unhelpful error message but at the least the forum support helped me resolve my problem, so thank you.

1 Like

Hi @renpub, thanks for sharing your solution.

I just wanted to say that MainWP is not actually hardwired with a path to openssl.cnf. It simply uses default OpenSSL library settings. This incorrect path issue is actually a known issue of PHP on Windows.

In case I am missing something here, we are open for pull requests.


Thanks so much, you just solved the issue for me…


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.