"jump to site" opens loginpage

Hi, while looking for a good maintenance solution for my wordpress sites, i tried out the free version of MainWP.

All my installations, including the mainwp installation, are hosted on the same shared hosting environment.

I connected all wordpress sites successfully and i am able to update/configure all the stuff.

But one website has the problem, that the “jump to site wp admin” (direct login) is not working, instead I am just getting the login screen and I am not logged in my page directly.

I am using PHP 7.4, installed a total new certificate, renewd my .htaccess, updatet all plugins and wp to max, disabled all plugins. In short, I failed fixing it on my own.

I investigate on the action logs in mainwp, but there are no informations about that.

So I decided to ask you guys, if you have any tips for me how to find the solution.

Hi Thomas,

Can you please tell me do you use iThemes Security plugin on the child site in the issue?

If that is the case, please try to disable the Filter Long URLs option in the System Tweaks section and see if that helps.

If not, please let me know so we can continue troubleshooting:

Hi Bogdan, thank you for the fast reply!

Yes, i am using iThemes Secuirty (on all my Clients)
No, the Filter never was active - i checked again, that this feature is disabled.
I also deactivated all my plugins and deleted iThemes for testing, but still not working.

So i would need your help for further troubleshooting :frowning:

edit: and i got NO entry in the activity Log, which i installed on client site. If i try to log in with the wrong passwort i can see a invalid login, but if i use the “jump to site” function, i do not get any entry

Hi Thomas, thanks for getting back to me.

Ok, so the other most common reason for this error is when users connect sites as HTTP while the child sites are set to HTTPS protocol. Can you please verify that your child site is connected as https:// in your MainWP Dashboard?

I can verify, that i am 100% connected with https. To ensure this, i did a fresh connection process about 3-4 times in the last 4 days.

Thanks Thomas for the update

Can you send me temporary access to your dashboard and one of the sites that don’t work as expected via private message so I can check this further?

the not working child had at the wp general settings the value “https://www.domainname.com” but i addet all my childs without “www” in MainWP. So my solution was to change the wordpress general settings of the child to “https://domainname.com”.

May it had also worked, if i’ve addet the child to mainwp including the “www”.

Thanks for the awesome support, even if i’ve not bought pro license yet.

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.