Lighthouse extension error

Hi,
I have installed the Lighthouse extension and connected the Google API key. When i run “audit all sites” every site shows a pending icon for more than 20min. In the browser console i get this error:

load-scripts.php?c=0…n-async&ver=6.5.5:2 Uncaught 
ReferenceError: mainwp_lighthouse_action_start_next is not defined
    at HTMLDocument.<anonymous> (admin.php?page=Exten…e=95eb259109:1290:6)
    at e (load-scripts.php?c=0…c&ver=6.5.5:2:27028)
    at t (load-scripts.php?c=0…c&ver=6.5.5:2:27330)
(anoniem)	@	admin.php?page=Exten…nce=95eb259109:1290
e	@	load-scripts.php?c=0…n-async&ver=6.5.5:2
t	@	load-scripts.php?c=0…n-async&ver=6.5.5:2
setTimeout (asynchroon)		
ce.readyException	@	load-scripts.php?c=0…n-async&ver=6.5.5:2
(anoniem)	@	load-scripts.php?c=0…n-async&ver=6.5.5:2
e	@	load-scripts.php?c=0…n-async&ver=6.5.5:2
t	@	load-scripts.php?c=0…n-async&ver=6.5.5:2
setTimeout (asynchroon)		
(anoniem)	@	load-scripts.php?c=0…n-async&ver=6.5.5:2
c	@	load-scripts.php?c=0…n-async&ver=6.5.5:2
fireWith	@	load-scripts.php?c=0…n-async&ver=6.5.5:2
fire	@	load-scripts.php?c=0…n-async&ver=6.5.5:2
c	@	load-scripts.php?c=0…n-async&ver=6.5.5:2
fireWith	@	load-scripts.php?c=0…n-async&ver=6.5.5:2
t	@	load-scripts.php?c=0…n-async&ver=6.5.5:2
setTimeout (asynchroon)		
(anoniem)	@	load-scripts.php?c=0…n-async&ver=6.5.5:2
c	@	load-scripts.php?c=0…n-async&ver=6.5.5:2
fireWith	@	load-scripts.php?c=0…n-async&ver=6.5.5:2
fire	@	load-scripts.php?c=0…n-async&ver=6.5.5:2
c	@	load-scripts.php?c=0…n-async&ver=6.5.5:2
fireWith	@	load-scripts.php?c=0…n-async&ver=6.5.5:2
ready	@	load-scripts.php?c=0…n-async&ver=6.5.5:2
P	@	load-scripts.php?c=0…n-async&ver=6.5.5:2

I saw a post from @Rushty where the error is almost the same but his soultion did not work for me.

Hey @LucasHuls

I couldn’t reproduce this issue on my test Dashboards. The audits are completing and I am not seeing that console error.

The audits can take up to a minute, and that is entirely dependent on Google’s PageSpeed API, but they should never take anywhere close to 20 minutes.

Can you please post the community system report from your MainWP Dashboard for review? The report is located in your Dashboard under Info → Server, on the top right of the page.

Be sure to use the button like the one below; this button hides all your private information:

image

Pressing the button auto-copies the report to your clipboard then just paste it in a reply here.

This is my community report:

WordPress Check Required Detected Status

FileSystem Method = direct direct Pass
MultiSite Disabled =true true Pass
WordPress Memory Limit >=64M 40M Warning
WordPress Version >=6.2 6.5.5 Pass

PHP Required Detected Status

cURL Extension Enabled =true true Pass
cURL Timeout >=300 seconds 60 Warning
cURL Version >=7.18.1 7.87.0 Pass
OpenSSL Version >=OpenSSL/1.1.0 OpenSSL/1.1.1w Pass
OpenSSL Working Status Yes Yes Pass
PCRE Backtracking Limit >=10000 1000000 Pass
PHP Allow URL fopen N/A YES
PHP Disabled Functions N/A No functions disabled.
PHP Exif Support N/A YES
PHP IPTC Support N/A YES
PHP Loaded Extensions N/A Core, PDO, Phar, Reflection, SPL, SimpleXML, Zend OPcache, bcmath, bz2, calendar, ctype, curl, date, dom, exif, fileinfo, filter, ftp, gd, gettext, gmp, hash, http, iconv, imagick, imap, inotify, intl, json, libxml, litespeed, mbstring, mcrypt, mysqli, mysqlnd, openssl, pcntl, pcre, pdo_mysql, pdo_sqlite, posix, propro, raphf, readline, session, shmop, soap, sqlite3, standard, tokenizer, xml, xmlreader, xmlrpc, xmlwriter, zlib
PHP Max Execution Time >=30 seconds 30 Pass
PHP Max Input Time >=30 seconds -1 Pass
PHP Memory Limit >=256M 256M Pass
PHP Post Max Size >=2M 32M Pass
PHP Safe Mode Disabled =true true Pass
PHP Upload Max Filesize >=2M 32M Pass
PHP Version >=7.4 7.4.33 Pass
PHP XML Support N/A YES
SSL Extension Enabled =true true Pass
SSL Warnings = empty Pass

MySQL Required Detected Status

MySQL Client Encoding N/A utf8
MySQL Mode N/A NO_ENGINE_SUBSTITUTION
MySQL Version >=5.0 10.6.18-MariaDB-cll-lve Pass

Server Configuration Detected Value

Accept Content text/html,application/xhtml+xml,application/xml;q=0.9,image/avif,image/webp,image/apng,/;q=0.8,application/signed-exchange;v=b3;q=0.7
Accept-Charset Content N/A
Architecture 64 bit
Gateway Interface
HTTPS ON
Memory Usage 7.67 MB
Operating System Linux
Request Time 1720712399
Server Protocol HTTP/2.0
Server self connect Not expected HTTP response body:
Server Software Apache
User Agent Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/126.0.0.0 Safari/537.36

MainWP Dashboard Settings Detected Value

Abandoned plugins/themes tolerance 365
Basic uptime monitoring enabled Yes
MainWP Dashboard Version Latest: 5.1.1 | Detected: 5.1.1 Pass
MainWP legacy backups enabled No
Maximum number of pages to return
Maximum number of posts to return
Maximum simultaneous install and update requests3
Maximum simultaneous requests 4
Maximum simultaneous requests per ip1
Maximum simultaneous sync requests 8
Minimum delay between requests 200
Minimum delay between requests to the same ip1000
Number of connected sites 6
Optimize data loading No
Plugin advanced automatic updates enabledYes
Primary Backup System WPvivid Backup for MainWP
REST API enabled No
Site health monitoring enabled Yes
Theme advanced automatic updates enabledYes
Use WP Cron No
WP Core advanced automatic updates enabledYes

Extensions Version License Status

Advanced Uptime Monitor Extension 5.3.1 Active Pass
MainWP Clone Extension 5.0 Active Pass
MainWP Custom Dashboard Extension 5.0.1 Active Pass
MainWP Database Updater Extension 5.0.4 Active Pass
MainWP Domain Monitor Extension 5.0.2 Active Pass
MainWP Google Analytics Extension 5.0.1 Active Pass
MainWP Lighthouse Extension 5.0.2 Active Pass
MainWP Pro Reports Extension 5.0.4 Active Pass
MainWP White Label Extension 5.0 Active Pass
WPvivid Backup MainWP 0.9.36

Plugin Version Status

Admin and Site Enhancements (ASE) 7.1.3 Active
MainWP Dashboard 5.1.1 Active
WPvivid Backup MainWP 0.9.36 Active

Thanks for the system reports. Nothing in it stands out as an obvious issue.

Can you try performing an audit in a different browser, preferably in an Incognito/Private browser window without any browser extension running?

Should the issue persist, please open a private Help Desk ticket so we can collect some additional information & investigate further.

And please refer to this Managers thread by its URL in the ticket.