MainWP Child Plugin not detected

I am trying to configure my first child site to main WP which is running on local machine ,I tried everything like add FW record in cloudflare , disable all plugins and than retry ,I also communicate to Hostinger team to check if any firewall is blocking and they confirmed nothing ,please help to get it work .

I also try DNS lookup and it is connecting to my correct domain IP .
Below is server report from main WP -

### Server Info                    Required                                               Detected                                     Status   ###

MainWP Dashboard                   
MainWP Dashboard Version                                                                             Pass        
MainWP Upload Directory            Writable                                               Writable                                     Pass        
MainWP Extensions                  
No installed extensions            
WordPress Version                  >=3.6                                                  5.6                                          Pass        
WordPress Memory Limit             >=64M                                                  40M                                          Warning     
MultiSite Disabled                 =true                                                  true                                         Pass        
FileSystem Method                  = direct                                               direct                                       Pass        
PHP Version                        >=5.6                                                  7.3.5                                        Pass        
PHP Safe Mode Disabled             =true                                                  true                                         Pass        
PHP Max Execution Time             >=30 seconds                                           1200                                         Pass        
PHP Max Input Time                 >=30 seconds                                           600                                          Pass        
PHP Memory Limit                   >=128M                                                 256M                                         Pass        
PCRE Backtracking Limit            >=10000                                                1000000                                      Pass        
PHP Upload Max Filesize            >=2M                                                   300M                                         Pass        
PHP Post Max Size                  >=2M                                                   1000M                                        Pass        
SSL Extension Enabled              =true                                                  true                                         Pass        
SSL Warnings                       = empty                                                                                             Pass        
cURL Extension Enabled             =true                                                  true                                         Pass        
cURL Timeout                       >=300 seconds                                          60                                           Warning     
cURL Version                       >=7.18.1                                               7.64.0                                       Pass        
cURL SSL Version                   >=OpenSSL/0.9.8l                                       OpenSSL/1.1.1b                               Pass        
PHP Allow URL fopen                YES                                                    
PHP Exif Support                   YES ( V7.3.)                                           
PHP IPTC Support                   YES                                                    
PHP XML Support                    YES                                                    
PHP Disabled Functions             No functions disabled.                                 
PHP Loaded Extensions              Core, PDO, Phar, Reflection, SPL, SimpleXML, Zend OPcache, bcmath, bz2, calendar, cgi-fcgi, ctype, curl, date, dom, exif, filter, ftp, gd, gettext, hash, iconv, imap, json, libxml, mbstring, mysqli, mysqlnd, openssl, pcre, pdo_mysql, readline, session, soap, sodium, standard, tidy, tokenizer, wddx, xdebug, xml, xmlreader, xmlrpc, xmlwriter, xsl, zip, zlib
MySQL Version                      >=5.0                                                  8.0.16                                       Pass        
MySQL Client Encoding              utf8                                                   
Server Info                        
Server Software                    nginx/1.16.0                                           
Operating System                   WINNT                                                  
Architecture                       64		 bit                                               
Server Protocol                    HTTP/1.0                                               
HTTPS                              ON                                                     
Server self connect                The HTTP response test get an error "cURL error 60: SSL certificate problem: self signed certificate"Not expected HTTP response body:
User Agent                         Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/87.0.4280.141 Safari/537.36
Gateway Interface                  CGI/1.1                                                
Memory Usage                       4.42 MB                                                
Request Time                       1610512178                                             
Accept Content                     text/html,application/xhtml+xml,application/xml;q=0.9,image/avif,image/webp,image/apng,*/*;q=0.8,application/signed-exchange;v=b3;q=0.9
Accept-Charset Content             N/A                                                    
MainWP Settings                    
Number Of Child Sites              0                                                      
Use WP-Cron                        No                                                     
Optimize for Shared Hosting or Big NetworksNo                                                     
Automatic Daily Update             Install trusted updates                                
Abandoned Plugins/Themes Tolerance                                                        
Maximum number of posts to return                                                         
Maximum number of pages to return                                                         
Primary Backup System              Default MainWP Backups                                 
Maximum simultaneous requests      4                                                      
Minimum delay between requests     200                                                    
Maximum simultaneous requests per ip1                                                      
Minimum delay between requests to the same ip1000                                                   
Maximum simultaneous sync requests 8                                                      
Minimum simultaneous install/update requests3                                                      
Active Plugins                     
MainWP Dashboard                                                         Active                                       

Hi All - Finally figured it out ,issue was of - "The HTTP response test get an error “cURL error 60: SSL certificate problem” .In windows if you are using local by Flywheel ,need to update ca-bundle cert ,I found a good discussion and mentioning url which may be helpful .I took 3 days to find it.

  1. Take a backup of the site!
  2. Navigate here to download the cacert.pem file that most of the internet uses for this stuff:
  1. Replace WordPress’ ca-bundle.crt file with the recently downloaded cacert.pem . To be specific:
  • Delete WordPress’ ca-bundle.crt
  • Move cacert.pem file to wp-includes/certificates/caceert.pem
  • Rename wp-includes/certificates/caceert.pem to wp-includes/certificates/ca-bundle.crt

If still not resolved do below -
Open your - \site-dir\conf\php\php.ini.hbs and add - openssl.cafile=C:\Program Files\Common Files\SSL\cert.pem ,this is the same what you downloaded and just need to rename.

Discussion on it -

1 Like

Hi Ravi,

Thanks for reaching out and sharing the solution.

I am sure this will help other users that stumble upon the same problem.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.