Mainwp_stream DB table isn't created

Before anybody says, I already know the other threads about this issue!
I have a newly built site that doesn’t have that many plugins. I installed MainWP and then Child Reports and get the message:
The following table is not present in the WordPress database: wp_mainwp_stream
In my database, I did have the other table “mainwp_stream_meta”, but not this one. At first I tried to make sure the MySQL user has all permissions, and they do.

Note that the latest version from the WP plugin store area was 2.0.8.
I found another thread on this issue, and the fix was provided by downloading an alternate version of Child Reports, see here: The following table is not present in the WordPress database: wp_mainwp_stream - #4 by bogdan

So then, for my issue, I removed the plugin I had (2.0.8) and installed that one. That plugin also reported itself as 2.0.8, I don’t know why. I did a folder compare between the two and there are a lot of differences.

Anyway, after installing the “fix” plugin, and then running the reset database function, the DB tables were both created. When I ran the DB reset feature on the normal plugin, it didn’t work.

My question is, that other “fixed” plugin was from three months ago, is there something in there that is going to be released in the next version? Is the latest plugin from the WP store buggy, does it fail for everyone? If not, what is making it not create tables for some users and not others?

Also, when I search the code of the plugin, I see many references to the table “mainwp_streammeta”, such as class-admin.php, class-db-driver-wpdb.php, class-query.php, class-uninstall.php. Why is it using this name when it seems like the actual table uses “mainwp_stream_meta” with the extra underscore? Is that a backward compatible thing, or is there a bunch of code trying to use a table that doesn’t exist? Could that be causing bugs?

Ultimately I just want to know what’s wrong with 2.0.8, is it safe to use on other sites or does it have bugs? What about this other version from 3 months ago, will that be updated to a new version number and be released? Why aren’t the DB tables being created? Why does the code reference the meta table with the wrong spelling?

I’m looking for an update when all this will be sorted out and when a new version will be released.


Hi @zackw

The version available in the repository does not have a bug that causes the DB table to fail for everyone. The issue occurs only for some users, but we haven’t been able to isolate the specific circumstances under which the DB fails.

That is why we created the tool for Uninstalling the MainWP Child Reports database, which we distributed on this forum. That tool will be integrated into the official version soon, but I don’t have an exact timeframe.

1 Like

Ok thanks.
I was confused because the plugin in the repo does have the DB refresh feature, which didn’t work. The plugin downloaded in the forums also had the same feature (looked like the same thing), but that one worked.

Anyway, if it helps, the other table mainwp_stream_meta was created, just not mainwp_stream. My particular site had never had MainWP installed before, it’s actually a pretty newly built custom site using Oxygen builder. It’s hosted on LiquidWeb on a VPS running Plesk.

Thanks again!

1 Like

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.