MainWP unable to automatically install or activate extensions

MainWP Dashboard Version 4.1.11
WordPress 5.9
PHP 7.4.25
nginx 1.18.0

I tried to use the automatic buttons to install and activate extensions on the MainWP dashboard but it refused to accept my login. I am just evaluating the product so I’m only testing with free extensions and I don’t have a Pro subscription.

If I enter the login details and click the Verify My Login button I do see the “Account verification successful” notification on the screen, but clicking either the “Install Extensions” or “Activate Extensions” buttons results in the message: “Error : The password you entered for the username myname is incorrect. Lost your password?”. (Showed my actual username rather than “myname”.)

I also tried the same thing using my email address instead and got the same message except with the email address rather than the username. The password is almost certainly correct as I have also used it to login on

There was no related error in my server log.

I was able to manually install the extensions through the WordPress plugin system, and manually activate them by pasting in API info from

If this is a feature that is only available with a subscription then maybe the error should be different.

Hi @moberley,

I tried to duplicate this problem but I couldn’t.
Can you please try to reset your password on and try again after that?

It works as expected now after changing the password. Thanks I wasn’t sure if I should have posted this as a support request or a bug.

I am not sure why that would have made a difference but it did. It is an old account though as I did try setting up this product several years ago but stopped working with it in the interim. So perhaps that is the reason.

thanks for letting us know that the problem is resolved.
I am also not sure what made the difference, but I have seen in the past that helped in a few similar cases.

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.