OpenSSL on Local by flywheel

I am testing MainWp locally. I try to connect a child site to the site where MainWp is installed in a Win10 environment.
I can’t connect because I get the following error "“error:02001003:system library:fopen:No such process”.

I followed what is written on this page

… but it doesn’t work.

The result of the phpinfo() gives this:
Openssl default config=C:\Program Files\Common Files\SSL/openssl.cnf

In the “Common files” folder there is no SSL directory. So I guess that’s where it comes from.

How can I correct this error? Thanks for your help.

1 Like

Hi @Jomus

Please try performing a search using File Explorer or a similar application to locate openssl.cnf file. If you are unsuccessful, perhaps the best would be to contact Flywheel support and have them provide you with the exact path to the openssl.cnf file.

After you have the location, save it in Settings > Advanced Settings using usual Windows directory structure conventions, for example: c:\apps\xampp\apache\conf\openssl.cnf


I’ve managed to find that the path of openssl.cnf file in Locals by flywheel installation should be: /usr/lib/ssl/openssl.cnf

In case it changed since, here’s how you can get this value:

  • Click on the i beside the Local site’s PHP version to open a PHP info page
  • Scroll to the openssl section
  • Check the value of Openssl default config

That path should be the same whether you’re running Locals on macOS or Windows.

More information can be found here on Locals forums.

Hi Bojan,

As you could read in my previous message, I succeeded in recovering via the i button the path.
I rewrite below the result:
Openssl default config=C:\Program Files\Common Files\SSL/openssl.cnf

Finally I found an openssl.cnf file in the folders of a WordPress extension. I put the path and it worked.

Thanks for your help.

1 Like

My pleasure. I’m glad you managed to work it out.

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.