Possible Cache clearing bug / feedback

Updated to the Beta dashboard plugin and also updated 3 test / dev sites that have cache plugins installed.
One site uses WP Fastest Cache and the other 2 use Litespeed cache, (latest version).

Clear caching function has been activated and after sync it the dashboard correctly picked up the cache plugins installed.

I’ve uploaded an older version of Yoast to all sites and resynced the sites. Updating Yoast via MainWP would presumably clear the cache as well.

Yoast was updated correctly but the ‘Last purged cache’ column still showed ‘never purged’
Further re sync and same result.

The site with WP fastest cache did eventually show a ‘last purged’ time and date but it only appeared after a couple of hours. The 2 sites on Litespeed still show never purged.

I’ve since repeated the procedure with Yoast (downgrading and upgrading) and still the same result so unsure if the cache is being cleared or if the report is just not updating.


1 Like

Hi Dave,

thanks for reporting this.

@kwcjr Can you please check this further?

@mono Can you please check this version & let me know if this works better for you?

MainWP Child 4.2 beta(2)

After purging the cache, check the Child Site’s /upload folder for the file “last_purge_log.txt” If this states that the cache was purged then the method should have succeeded without an issue.

1 Like

Tested with Version 4.2-beta1

Rolled back theme
Refreshed the child theme on the admin panel
It detected the theme needed an update
Attempted to update the theme
Theme update failed

Reverted tot he current live version of MainWP Child the updated worked as expected.

I’ll try again with beta 2 posted above.

Update… downloaded the version linked above in admin it still shows version as Beta 1
Theme update failed with this version installed.

Hi Keith
Thanks for the reply. I’ve updated the plugin on the child sites, re synced and then repeated the update procedure.
Nothing was showing intially - still showing as ‘never purged’. Checked the last_purge_log.txt and it showed that the cache had indeed purged.
It took another re-sync, after the updates to show the last purged time and date on the dashboard.

Not sure if that is the way it should work or not, but it appears the cache is clearing just not reported until after a further sync.


@mono ok great thank you for the update! That sounds like correct behavior now. I will be looking into that caveat in order to have the UI update right away. Thank you very much for testing this nd confirming that it’s working.

I will also be testing this further on a Known Working LS Server as well for stability.

1 Like

@Edward_O_Rourke Thanks for the detailed test. The internal version will be the same I simply re-named the download to be easily tracked on this thread only.

Hey @mono Just letting you know that we are looking into the “re-sync” bug & it will be working as intended when released.


Thanks @kwcjr that’s great news :smile:

1 Like

@mono 4.2 is Live & that bug fix is included. Thanks everyone for the testing. :vulcan_salute:


This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.