"Public key already set" when adding new site

Hi there!

For some reason, I can’t add one particular site to the MainWP dashboard.
I get this error: “Public key already set. Please deactivate %26 reactivate the MainWP Child plugin and try again.”

I already tried the following:

  • Deactive and Activate the MainWP Child plugin
  • Complete remove and add the MainWP Child plugin
  • Removing all (as far as I could find) MainWP related data from the child site MySQL database
  • Clearing Wordpress session_tokens from the child site

Nothing helps.

I also searced for any website URL reference in the MainWP Dashboard MySQL database, to check if maybe some conflicting data is present (none found)

The odd thing is: When I create an identical staging site with WP Staging and try adding this to the MainWP Dashboard, the site is added succesfully! How is this possible, what can cause this issue where I can’t add this particular site?

I hope someone can point me in the right direction.

Best regards,

Hi Jeroen, have you tried to deactivate all plugins on the site temporarily (except for MainWP Child) and see if that helps?

Hi Bogdan,

Thanks for your fast reply.
I thought of this and normally would never ever do such things on a live website, that’s what’s a staging env is for (and where the MainWP connection worked).
But for the sake of urgency I disabled all plugins except MainWP Child. The connection has now succesfully been established and I enabled all plugins again.
I have no clue why it works this way and what the error message is about, and I hope it won’t happen to other sites either. :slight_smile:

Thanks for your help and have a nice day!


1 Like

@indepenmedianl In situation such as these where you are having an issue on a Production site that is only replicated on a Production site, I like to throw up a Maintenance page allowing you the environment to fix any issues quickly.

You say you were connected to this Child Site via a Staging Server; MainWP only allows you 1(one) connection at a time to each Child Site.

This may be why you see that error message because there is already an active link established to that Child Site via the Staging Server. When you moved it, it took that data along with it. Deactivating the MainWP Child Plugin breaks this connection freeing up the Key allowing you to reconnect.

1 Like

@kwcjr Keith, thanks for your reply.

The ‘Public key already set’ error appeared directly, on the first time, I tried to connect the Child site to the Dashboard.
I then tried deactivating / activating / even removing & re-adding the plugin on the Child site as suggested, but that didn’t help.
Only after then, I created a staging site (same files, settings, plugins - on a subdomain and different database but same server) and tried to connect that site as Child site to the Dashboard. That connection was succesful immediately.
So I’m pretty sure there wasn’t a double connection.

But I guess the process of some plugins being re-activated in the creation process of the staging site was the key for MainWP to work again. So doing the same on the production site fixed the issue.
Still not sure why and what this has to do with the public key error, but fingers crossed this was a one-time occasion :slight_smile: :+1:t2:

Thanks again for this wonderful plugin, and have a nice day,


@indepenmedianl Oh, that’s great news! I’m glad everything is working now.

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.