Question Change URL WP-admin (plugin WPS Hide Login)

Hello ,

For one of my website i changer the XXX Sex - Free Porn Videos on XXX.com address to another URL for more security (with WPS Hide Login).
Everything works fine with MainWp except for one :
When I’m on the dashboard of my sites and want to connect my site administration with the “Jump to the WP admin site” button. Unfortunately it doesn’t work anymore. Is it possible to modify this to make it work ? I didn’t find in the dashboard settings to change the path.

Thanks in advance
Clement

WPS Hide Login is functionality in the category “security through obscurity”, which is considered a bad practice. You can compare it to trying to hide the front door of your house instead of using a good lock on the door. If the lock is good, you don’t need to hide the door. And if you hide the door, you even might forget where it is yourself. So it can do more harm than good.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Custom /wp-admin/ URL should not affect the MainWP functionality in any way.

There is probably something else causing this error. Please try to deactivate all security plugins on the child site temporarily and see if that helps.

Hello,

I’m also using the WP Hide Plugin and I’m also rewriting the default /wp-admin and /wp-login.php paths. This should only prevent random attacks and scanning, but this is not the point.

In my case the auto login works, but a lot of other features like the “Auto Update” do not. If I click on “Show Themes” (/wp-admin/admin.php?page=ThemesAutoUpdate) or “Show Plugins” (/wp-admin/admin.php?page=PluginsAutoUpdate) I get this error:

MainWP Child plugin not detected or could not be reached! Ensure the MainWP Child plugin is installed and activated on the child site, and there are no security rules blocking requests. If you continue experiencing this issue, check the MainWP Community for help.

When I check the access logs I see, that MainWP is trying to access /wp-admin/admin-ajax.php instead of the custom URL.

Could you please provide an option to set a custom admin URL?

Hi Manuel,

Thanks for sharing that info. I haven’t seen it before.

Just to be 100% sure, are you able to just temporarily restore default paths to one child site and retest this?

Hello Bogdan,
sorry for late response. Switching back to default paths this is no problem and all is working as expected. In the access logs I’m seeing that MainWP is trying to access the default paths.

Hi Michael,

Thanks for the update. It is very strange.

What about setting the same config with a different plugin?