Some sites keep prompting for credentials

We have quite a number of sites but we have 5 or so sites that I am not able to connect to automatically.

I have tried the following:

  • remove child plugin, reinstall
  • change password

I then test the connection which is successful, but the next time accessing the site I am required to manually enter the credentials.

I’ve noticed this issue seems to happen with sites that were staging and were migrated to live. We have some other sites where this was initially resolved by refreshing the plugin and we set a new password but some have not recovered.

The sites that are affected are all similar hosting plans in the same host to other sites that are working without issue.

What other steps can I take to get these sites working again.

Hi @gjohncock

Do I understand correctly that the issue here is that you cannot log in to WP Admin of the child site through MainWP Dashboard without being prompted to enter a username/password for the child site?
If so, does the other functionality of MainWP Dashboard works as expected (synchronizing, updating plugins…)
If not, please attach screenshot(s) so we can understand the context better.

Were the sites added to the MainWP Dashboard while they were in staging, meaning that they had different URLs than what they have now?

Hi Bojan,

I ran the following tests…

  1. Attempted to connect to child site by clicking the WP Admin icon for the site - took me to the Login prompt
  2. Returned to MainWP and opened the Site details
  3. Tried a Sync, this worked (green tick)
  4. Tried updating a plugin, this worked
  5. Tried updating 2 templates, this worked
  6. Tried to connect to child site again by clicking the WP Admin icon, didnt work, took me to the login prompt

This was a staging site. The live site already existed independently of the staging site when we started using MainWP but the live site has the same connection issues.

In any case both sites have had their passwords changed as well as removing the mainWP child plugin and reinstalling it and running a successful Test Connection step.

No errors appeared in the interface.

Hope this helps

Greg J

Since it “was” a staging site, I assume it has been deployed into production?
If that’s the case and the URL of the site has changed, that would explain why you can’t log in to the WP Admin.

Try removing the site that “was” a staging site from the MainWP Dashboard and re-adding it, while making sure to use the current site URL, and see if that helps.

OK I see what you are trying to do.

Just so you know…
the staging site is on a completely separate domain (so not sharing a database with the live site) ie:

  • live site might be:
  • staging site would be like:

We use the Duplicator plugin to move the site from staging.

So, the staging site as such has never had the live url added to it.

The live site has had a find/replace to remove the staging url and replace with the live url. I have scanned the database, even as an exported text file, and could not find any evidence of the old URL in it.

In addition to that, we do not use the define statements in the config.php file for HOME or SITE url settings, these are only ever stored in the database.

I think I have got the live site working. I noticed that the url specified on options table contained a www whereas the entry I created in mainwp did not. Now they are the same it appears to be working.

The staging site, as it already has a subdomain is set up to operate without one so is the same as what is in mainwp. I tried disabling all plugins (apart from mainwp child of course) and tried changing themes and did not have any luck at all, still prompts for credentials.


Thanks for the update.

Would you mind opening a private Help Desk ticket so we can collect some additional information & investigate further?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.