Unable to create directory. Is its parent directory writable by the server

Hello! First time user here!

I’ve been getting this message when trying to reconnect to a Main WP Child Site:

Unable to create directory /hermes/bosnaweb08a/b2472/ipg.ncsabcom/temp/updraft/mainwp/. Is its parent directory writable by the server%3F

I have Online-Chatted with Tech Support at the website host, iPage, but they are mystified by it. They said it is a plugin issue, but I’m not too sure about that. It seems to ALSO happen with an Updraft plug when it is trying to create it’s backup folder. So I’m not sure whether it is Updraft, MainWP, or what?

Any ideas?

Thank You Very Much,
David Scott Lynn

Hi David, can you please tell me has this child site been migrated/cloned from a different server recently?

Thank You, Bogdan.

No, it’s been same web host for a long time. Many years, actually.

I’m wondering what the folder pathway would be so I could temporarily turn up permissions for a test?

OH, I did have same problem with Updraft Backup plugin and an old Theme related plugin (Aspen, now deprecated). Could not upgrade to Theme replacing Aspen (Weaver Extreme) because I could not save / download the Theme & Plugin settings. I struggled with it for over a YEAR, had to backup manually. Then a couple nights ago, I was messing around with different things, and somehow it got fixed on Updraft, but NOT on Aspen. So this is pretty weird.

UPDATE: Tried deactivating ALL plugins except MainWP, then disabled it, then reenabled it, TWICE. Getting this message:

Public key already set. Please deactivate & reactivate the MainWP Child plugin and try again.

Which did not work. So I reenabled all plugins, tried disable/able AGAIN, did not work. And still getting original message on top of plugin page:

MainWP Upload Directory
Writable Unable to create directory /hermes/bosnaweb08a/b2472/ipg.ncsabcom/temp/updraft/mainwp/. Is its parent directory writable by the server? Warning

Thanks for the update.

Are you able to send me private massage with a temporary login to your Child Site so I can check something quickly?

Hello Bogdan! Sorry for delay, was with a client. … I’ve been searching for a PM button to send you a private message, but I cannot find one anywhere? Any clues on that?

BTW, if I knew what the folder path should be, I might be able to increase permissions temporarily???

Thank You!

@David_Lynn, - you may send a direct message to any person by clicking on there name. A window should pop up and give you the option to message them. If that button is not there, please open a help desk ticket so we can go over your Installation further in private.

The folder name is within the path given in the error message, one of the folders listed in this path most likely the temp folder.


Thank You Keith! I very much appreciate it.

And NO, that green message button does NOT show up in Bogdan’s detail window.
So I’ll do as you suggest about the help desk ticket.

Thank You Again,

Is there no one who knows what the folder structure is for MainWP, such that they can tell where this folder/ file path should be located?


Meaning, in which folder is the “/hermes/” folder located? I do searches in the WP File Manager, in FTP, and MySQL Database (MyPHP) and nothing comes up.

It was also a problem for Updraft Backup and a Theme-Related plugin. I seem to have resolved the Updraft Backer upper but, I’m embarrassed to admit I do NOT know what I did that fixed it!

I’ve been asking around the internet on all this for over a YEAR!

Thank You Very Much,
David Scott Lynn

@David_Lynn I’m pretty sure that folder is on your server. Such as /home/cPANEL ACCOUNT NAME HERE/b2472/ etc.

When you log into cPanel > Filemanager what does the folder say at the very top on the left hand side? is it “/hermes/bosnaweb08a/”

P.S. DM’s have been unlocked for Users with lvl 0, so you should be able to DM now as well.


At this URL:

I tried a coule of his suggestions. The combination that worked was to reset permissions at wp-content/uploads to 777 (775 did not work) AND, go to Settings/Media in WP sidebar and in the “Store uploads in this folder” text box, put the text ** wp-content/uploads ** (NO asterisks).

And, of course, I reset the Permissions back down to more secure level.

Not only did that allow MainWP to complete the Sync process, it allowed another Theme (the deprecated Aspen, now replaced by Weaver Extreme) to Save & Download backup data.

I’ve been messing with this for over a YEAR, and this guy at tipsandtricks-hq.com had the solution.

I don’t know how common this issue is, but I’ve got it fixed now. Hope it helps someone else.

Thank You,


@David_Lynn I am super glad that you figured it out. Now you can mark yourself as the Solution! :smiley: Sweet!
I think the reason it wasn’t writable was because it was tying to upload above the Root of your WP site which is off limits to anything within the public_html folder. That URL string looks like your cPanel Root directory & “bosnaweb08a” is the account name.

Really glad you figured that out.

Yeah the default File / Folder permissions for WP are 755 Folder & 644 Files.

here is a bit more information on that Changing File Permissions – WordPress.org Forums

1 Like

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.