WooCommerce 6.5.0 minimum PHP version supported has been bumped to 7.2

Ideally you should already be using at least PHP 7.4 for any sites running WooCommerce if not 8.0.x or higher.

The WooCommerce 6.5.0 release was pulled due to some issues but a new release will be going out shortly.

WooCommerce core released version 6.5 but it was rolled back due to a fatal error on sites with WooCommerce Admin active.

If you have Analytics enabled in WooCommerce > Settings > Advanced > Features > Analytics but still can’t access it in the WP dashboard I would suggest, for now, while waiting for the new release (6.5.1), to roll back to version 6.4.1.