Cache Control spelling error in plugin options

I know this is a tiny little thing, but noticed today, see screenshot with spelling “Cloudflair”.

On another note, it would be good if there is a way to manually have MainWP clear a cache. Or tell me if id had an error clearing it or whether it even tried etc. I don’t have much in the way of status. For example it is supposed to clear cache after plugin updates, most sites it seems to work and updates the “last purged cache” date. But some sites continue to show an old date, like a month old, and never seem to really clear the cache. Or is it?
In other words, I can’t really tell if it’s working. Or if it’s just a glitch in recording the date, or if it had an error and couldn’t do it, etc. I have no manual way to force it to clear the cache to try again.
Just something to think about.


Hey @zackw

That typo has been fixed in a previous version of the Dashboard. Please check if there’s an update available.

As for the manual cache clearing - we have an open suggestion for that feature here: Cache Control Settings manually - MainWP
Please give it a vote.

1 Like

I don’t show any updates. On version of Dashboard. I clear cache and all that, still shows the spelling.

1 Like

That typo has been mentioned here, but it still exists in the file class/class-mainwp-auto-cache-purge-view.php
It even exists 36 times in that file, also in the code.
Tagging @kwcjr as he was working on this.


Thanks for the clarification.

The typo will be fixed in the next version of the Dashboard.


Thanks for bringing this up.

Looks like the spelling error was fixed in the UI for the General Settings but the Individual Settings page was still missed. Disregard the spelling errors in the code. These “spelling mistakes” are not breaking changes so as mentioned by @bojan these will be fixed in the next version.

Thanks again.

1 Like

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.