Cannot connect children with self signed ssl certificate

I am currently testing MainWP on my local dev system (Debian). All my WP sites are running on it as well and before going live I would like to test everything locally. I am using a self signed SSL certificate on this system which unfortunately prevents me from connecting a child.
Upon testing the connection I get this error message: “SSL certificate problem: self signed certificate”.
I already disabled the SSL verification in the enhanced settings but that does not help.
Is there any way I can use my self signed certificate?

Thank you

Edit: connecting via HTTP works fine but I still would like to use SSL.

Hi @OvalMedia

Welcome to the MainWP community.

Unfortunately, this is an unavoidable issue with self-signed certificates.
The only recourse is to try disabling SSL verification, and if that doesn’t help like in this scenario, to connect via HTTP.

The only other suggestion would be to investigate the possibility of using a Let’s Encrypt certificate, or similar, on your localhost domain.

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.