Can't add a site to MainWP Dashboard - already linked, but not

I have been in the process of migrating about 30 sites from a Linode to a GREAT Cloud-VPS hosting platform. I’m now battling with MainWP over the second site that this software INSISTS is linked to MainWP on my old server - despite the fact that I have removed the site from the old MainWP Dashboard AND deleted the child plugin from the new version of the site. Before activating the Child plugin on the new version of the site, I tried to add the site to my new version of MainWP Dashboard.

Look what I got:

Apparently I need t slap the software in the face to “bring it around” or pour 5 gallons of ice water on it to wake it up.

What, exactly, is the proper technique? 24 other sites migrated wonderfully, but this one just won’t deal with reality.

Thanks for any guidance you may offer!


1 Like

So now that I have the Dashboard recognizing that there was no plugin, I then activated the child plugin and tried adding the site again. Guest what? Now I get the “there’s already a link” error.

What to do?

1 Like

We have a tool that will reset your MainWP Child Site Plugin settings as if it was never installed.

Please find the plugin here. Simply install this like a normal plugin ON THE CHILD SITE ONLY. Once activated it will do its thing and deactivate itself.

After you are finished with the tool PLEASE remove it for security reasons.

If that doesn’t resolve the issue, then the culprit is most likely DNS cache.

Usually, after site migration, it can take up to a few days before the DNS cache clears from your Dashboard site server and DNS starts resolving properly.

I assume that your dashboard is still sending requests to the old IP address of the child site.

When you run the Test Connection feature and get a success message, do you get the IP address of the child site too? If yes, is it the correct IP?

If you want, you can wait for a day or two and see if the issue resolves, or if you prefer, you can ask your dashboard site host provider to flush DNS cache from the server and see if that speeds up the process.

Thank you Bojan - it is working now!


1 Like

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.