Cant add new Google Analytics client

All my Google Analytics are working fine, but now I tried to add a new client and this is not appearing in the list.
The property manager in GA is set up right.

I clicked Refresh Data, but then the new client does not appear.
Also when I click Refresh Data, I get a message: Settings Saved . But I did not click Save Settings, I clicked Refresh Data, it seems not to refresh.

Hi @alainL

Can you please elaborate a bit on what you did to add a new “client” (I assume you mean a GA property)?

In what list is not appearing? Please attach a screenshot if possible.

Please review the steps from this KB: Google Analytics Extension - MainWP Documentation
Every detail in it must be followed exactly for it to work.

I assume by this you mean that the Service Account email was added as a viewer to the GA property?

Does clicking Save Settings help?

Yes by client I mean a new property.

What screenshot you need? Its just a list of my current properties, but the new property is missing.

Clicking button Save Settings does not help. I need to click Refresh Data but that does not work.

Thanks for the update, @alainL.

For the property to show up in the dropdown list in the Google Analytics extension, it needs to be assigned to the child site.

Is the property not showing up in the dropdown when you try to assign it to the child site, or in the dropdown in the Google Analytics extension?

The new property is not showing in the dropdown of the extension.

Before the site can be visible in the dropdown in the Google Analytics extension, a property needs to be assigned to it on the Edit page of a Child site.

Please have a look at the “Assigning sites from your Google Account to Child Sites in your MainWP Dashboard” chapter of our KB:

Yes i know that. But its not there in the dropdown on the Edit site.

  1. On the Google Analytics > Manage Accounts page, is the relevant Account shown as Connected?

  2. Please make sure that the Service Account email is added as a Viewer to the GA property (and make sure that it is not instead added as a viewer for the entire Account)

  3. After that try saving the extensions settings once more and refreshing the data, and see if that helps.

  4. If the GA Property is still not visible in the Edit page of a child site after that, please open a private Help Desk ticket so we can collect some additional information & investigate further.

Please refer to this Managers thread by its URL in the ticket.

All seems fine but not working. I will send a ticket.

Just to provide an update on this:

The issue was caused by an issue with the GA Service Account email address that was used as a Viewer for the GA property.

After that was corrected, the issue was resolved and the property was visible in the MainWP Dashboard.

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.