Can't get oAuth from Google Analytics API

I’m struggling to connect with Google Analytics.

I follow this guide here Google Analytics Extension - MainWP Documentation and get stuck at step 7 which for me, the UI is different and doesn’t show that dropdown menu, but instead, goes straight to ask me if this is for internal or external use - and won’t allow anything other than External use since I don’t have a paid google Workspace account (never wanted or needed one).

I cannot progress beyond that point and so am quite stuck.
Any ideas or tips?

I have paid for MainWP and currently am trying to test it on a persona site, to see if I want to/can migrate client sites away from ManageWP, which just keeps getting worse and I want to leave behind.

Thanks in advance,

Hey @empirebase

Welcome to the MainWP community

External use should be selected so that part is fine, but can you please send us a screenshot of what screen you see instead of the one from step 7?

Feel free to blur out any identifiable information.

Thanks for the assist.

I just went into Google Console, to take the screenshots, and lo and behold, while not showing the dropdown list option right away, it’s taken me to a new page/screen with that dropdown.

I swear yesterday it did not do that. I was in circles for ages trying to see the same as the guide.

I’ll see how far I can get now.

1 Like

Ok, so I managed to follow all the steps this time.

I’ve gone to upload the JSON file to MainWP, and clicked the Connect button.
It tells me success, and in the Manage Accounts tab it shows me the account from the JSON.

But if I go to ‘visitor data’ tab and it tells me “No data available” and has a blue button to Connect Google Account again.

So, now I’m stuck there…!

Glad to hear you’ve managed to get past that screen.

After you add the account, the next step is to assign the Analytics properties to your Child Sites.
For that, please see the “Assigning sites from your Google Account to Child Sites in your MainWP Dashboard” section from the KB:

I cannot.

Despite being able to see the connected ‘project’ in GA settings area in MainWP, it simultaneously claims that there is no connection

IF I click the blue connect button, it takes me back to the screen to upload the JSON.

So, on a child site listing, there are no GA Properties to add, because the connection hasn’t worked.

So, on the child site…

This is an oversight on our end and we will fix that warning message.

If the account is showing as connected on the Manage Accounts page (which on your screenshot, it is), next step would be to assign the Analytics property to the relevant child site.

From this page, you click on Edit, and near the bottom of the that Edit page, you assign the property: Google Analytics Extension - MainWP Documentation

I finally found the Edit button - hiding way off to the right of the site listing. My bad for not spotting that.

Appreciate the assist very much.
I need to get used to a few more things and the UI so I can jump ship from ManageWP.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.