Can't reconnect Child Sites after migrating them to a new server

Alright, so another disconnection problem just happened. I moved three sites to a different server using database dumps and rsync and the MainWP connection just broke. Sites are working just fine though, there were no issues during the move. I usually move sites around according to their resource usage and this has never happened before, MainWP always kept on working.

Both origin and destination servers have the same software stack so nothing is different between them, and they’re running Ubuntu 22 LTS. After a few minutes of troubleshooting I ended up removing the sites and tried to add them again to the dashboard, but now I’m getting another error message.

It seems that the dashboard is trying to connect to the old IP address of the site, even though the DNS entry has a TTL of 5 minutes. I have also tried rebooting the server which hosted the dashboard in order to clear any DNS cache but no luck. Plus, pinging the site from the dashboard server returns the correct IP address.

So I’m at a loss here. Any help is appreciated. None of the issues mentioned in this thread ever happened before.

Hi @denisgomes

This issue seems to be unrelated to the original as reported in this topic, and it is likely due to the server-side DNS cache.

What error message do you get when you try to reconnect those sites?

You can try setting your Action Logs to debug before attempting the Reconnect and Connection Test to get more details.

Flushing the DNS cache from the server where the Dashboard is hosted may help resolve the problem if DNS is indeed what’s causing it.

1 Like

Alright, I feel stupid now.

Yes it was a DNS issue… But one that should not have happened in the first place :sweat_smile:

I moved the websites and updated the IPV4 address only, not the IPV6 address. Somehow I messed that up. And of course the dashboard is connecting via IPV6 only, so that’s why it seemed like a DNS caching thing.

I’m sorry about that, please close the topic LOL


This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.