Clone from Updraft Backups - not supported?

I have reviewed the documentation (MainWP Knowledge Base - MainWP Documentation) but when I try to Clone using the Clone from Backup option, it is looking for a single backup file, whereas by default, UpDraft creates 4 zip files (uploads, themes, plugins, others)

The Clone tool does not let me select all 4 at once, and it fails if I pick any single one of those zip files to start the process.

I set my updraft expertd setting to split archives only if over 800MB, my total site for all 4 sizs is only about 180mb, but it still insists on splitting up the backup into 4 zips.

How is Clone supposed to work with UpDraft?

( tried the quick clone feature, but it left me hanging - thats probably another issue tho)

@jandrwallace The MainWP Clone from Backup feature relys on the built in Legacy Backup Solution provided in MainWP.

You may read more about this feature here: MainWP Knowledge Base - MainWP Documentation

3. Create a Backup of the Source Site

This step requires the MainWP Legacy Backups feature enabled. If you have it disabled, enable it on the MainWP > Settings page and set it as a primary backup solution. Once you are done with the cloning process, revert your settings to the previous state.

1 Like

OK - Thanks for the reply. That makes sense now.
Hhowever, I still cannot get it working.
I did the php adjustments in this article (MainWP Knowledge Base - MainWP Documentation) so now it does not error out, but when doing a restore from backup it says extracting backup and updating your database, this might take a while, but 2 hours later, nothing going on. Not seeing any errors anywhere. Is there a specific log file I can check?

Just curious, is the Clone Extension pretty much complete, or is it in active development? If it is still getting the kinks worked out, I may stick with it. If it is not being actively developed further, I think I would prefer to use a different tool.

Thanks for the update. Yeah that to me sounds like you are timing out. If there was an error it would be reported within the WP Error Logs.

All of MainWP’s Extensions are actively developed unless they are on the Retired Extensions. list.

Could you please start by sending us your System Reports? This will give us a place to start. Please, do not take screen shots of your System Reports Page, however, instead save the reports to your computer & then upload those files to us by simply responding to this ticket.

  1. System Report file from your MainWP Dashboard which can be found at:
  • MainWP > Status > Server
  • Click Download System Report
  1. (If involved) System Report from one of your child sites which can be found at:
  • Child Site > Settings > MainWP Child > Server Information
  • Click the “Get System Report” button.
  1. Do you see any errors on the MainWP Error Logs Page?

Thanks for the reply.
I will send the main and child system reports shortly via a direct message to you.
The main WP Error was not active. I put debug on per your note, but have not retried the clone again to see what errors get thrown.

I will message you shortly with the two other reports.

1 Like

@jandrwallace Thank you for the DM.

I was able to look over your System Reports and I see that on the MainWP Dashboard & your Child Site both the Wordpress Memory Limit & cURL Timeout need to be set. Please add these to your wp-config.php files on both.

define( ‘WP_MEMORY_LIMIT’, ‘256M’ );
ini_set(“default_socket_timeout”, 300);

The other thing that could be happening is the backup is just large and it’s timing out on the server.

Please let me know how it runs after adding those lines.

Thank you very much. I was setting the curl timeout higher than normal but not 300, and I did have the memory_limit to 256, but it was done in php.ini, settings, not the WP_memory_limit in wp-config.php.

I have fixed those, and will report back.

Note for others - with my host, it turns out that with my particular host (Interserver) and maybe yours…
Editing the Home Directory PHP.INI file with the following 3 entries does not work.
Either they are blocked by my host, or they are the type of variable that cannot be set universally, and needs to be set with a separate php.ini file in each of the directories where you have wordpress installed.

max_execution_time = 300
default_socket_timeout = 300

So, @kwcjr, per the note above, I thought I had things set properly, but it turns out I did not. I am running out of time and will retest this as soon as I can, but may have to let this lie for a bit. Thanks for your help, fyi.

1 Like

@jandrwallaceYou still in need of assistance or did the php.ini changes fix the issue?