Domain Monitor Extension reports as domain expired when it is not

My domain of renewed on June 1. It has an expiry of June 15. When I checked this morning, the extension was showing it was not yet renewed and had expired. When I did a “Check Domain” only then did it show with the new expiry. I have frequency set for every day, so it certainly should have refreshed in the last 14 days.

On a side note, I also use Better Uptime and received a notification today that the domain expired as well.

I checked my registar this morning and confirmed the expiry date and that it was renewed on June 1.

Hi @Gary_Petro

Considering you have enabled automatic domain checks in the settings and that the extension properly fetched the data when you initiated a manual check, it is safe to assume that the issue is related to the WP Cron on which the Domain Monitor’s automatic checks depend.

If you want to make sure that WP Cron jobs are regularly triggered on your MainWP Dashboard, you can add your Dashboard site as a monitor to an uptime service such as Uptime Robot.

The Uptime Robot will ping your dashboard site regularly and make sure that all scheduled events are occurring.

1 Like

I have a server-based cron job set eveny 5 minutes.

… and I think you skipped over that I said I use Better Uptime, which has its own scheduling system. I have opened a ticket with them as well since it also missed the new expiry date being updated on June 1.

Hence, I feel there is something in common between MainWP and Better Uptime and how or where they are checking the expiry date of a domin.

Also, my MainWP dashboard site is also a site monitored by Better Uptime.

Thanks for the update.

Can you check on the Dashboard > Info > Cron schedules that the mainwp_domain_monitor_action_cron_start is running as frequently as it should, so we can eliminate that as a potential issue?

It is set for “Once every 5 minutes”.

Thanks for checking that, but can you please check in the Last Run column if the Cron schedule ran in the last 5 minutes?

It did show a last run within the last 5 minutes.

Now that I look over the cron schedule, things do seem a bit weird though, and not just for this job.

Thanks for the screenshot.

Considering both Better Uptime and Domain Monitor reported the same data, albeit incorrect, for that one domain, it seems most likely that the WHOIS server that we are both using experienced a temporary problem.

As for the two crons that are not running as scheduled (Lighthouse and Vulnerability Checker) - do you have those two extensions installed and active?

Does the Lighthouse have option for “Automated Audits” enabled in the Extension Settings, and does the Vulnerability Checker have " Schedule automatic checks" enabled?

I don’t think this was a temporary problem. This is not the first time this has happened. When it first did, I thought it was a glitch of some sort.

Lighthouse is installed and active. It is set to automatically audit once a day. Last audits show to be on May 15. I may have done a manual audit on that day.
Vulerability checker is set to check automatically on a dialy basis ans it looks to be doing so as the last run shows as June 19.

Only thing in the error log is “PHP Warning: Constant WP_MAX_MEMORY_LIMIT already defined in /home0/jukeboxhosting/ on line 93”.

I have always had an issue with MainWP and the cron. It used to not want to automatically sync. Now, it kind of does.

Thanks for the update.

Would you mind opening a private Help Desk ticket so we can collect some additional information & investigate further?

You should check that file, because it looks like the constant is defined twice (or more). This wasn’t a big issue with older PHP versions, but since PHP 8.x the warning/error is reported.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.