Error message: SSL: no alternative certificate subject

Hello guys
Has anyone of you ever had this problem?

It’s been two days and I haven’t found a solution. All domains have SSL certificates and everything is fine, but it refuses to connect!

Hi @Ghazi

Welcome to the MainWP community!

Can you please check the SSL for that child site with a third party tool like SSL Checker and see if everything looks good?

And you may try disabling Verify SSL certificate option when adding a site to skip this check:

Hi @bojan thank you for your reply.

Yes, it was verified through the third party SSL Checker for the child’s domain and everything is fine and there are no errors

Yes, I disabled Verify SSL certificate, but to no avail, and the problem continues with me
To do so, I followed the instructions here in This article, but to no avail, and the problem persists

Would you mind opening a private Help Desk ticket so we can collect some additional information on the website having the issue & investigate further?

And please refer to this Managers thread by its URL in the ticket.

1 Like

Hi @dennis I’m glad you saw my problem.

In fact, there is a ticket that was opened 3 days ago, but it is closed, and they tell me that there is another ticket for the same problem, but in the ticket section, it is the only one in front of me. My email correspondence with them may be a different ticket. I do not know.

Generally, this is the ticket link: My Ticket

I really hope you can help me. I have been in trouble for a few days

Hi @Ghazi

You had opened two separate tickets, perhaps accidentally, so we closed one of them and we are in communication with you via the other ticket (# 26236).

Once we have solved the issue, we will update the community via this thread with more information.

Hi @Ghazi,

thanks for your patience.

I just double-checked our system and noticed that you opened 2 tickets for the same problem, but no worries, that happens often, so our workflow is just to close one and work in the other. There is really not much sense working in 2 tickets, it can just create confusion. This is why Bojan closed one ticket after replying to the first one.

Regarding the problem that you have reported, the SSL verification fails with the error message “no alternative certificate subject name matches” (cURL 51 error), it usually happens when the certificate does not match the hostname.

The solution would be to contact the host and ask it to fix its certificate.

In some cases, it can be caused by a problem with the cURL ext. setup on the server, so maybe it would help to update the cURL version on the dashboard server.

In this specific case, I think that the problem comes from the cURL Version on your dashboard or its configuration. By reviewing the system report you sent us, I noticed that your dashboard and the child site are on the same server, and I saw that the Server Self-connect check fails… so maybe there is a problem, in the loopback connection, SSL verification does not work on your server.

When I test the connection from my Dashboard, SSL verification does not fail:

In any case, I would strongly recommend contacting your host support so they can check this and resolve it. SSL Cert verification process is not something that the MainWP plugin handles on its own, it’s all in the cURL process and all errors come from the server configuration.


Hello @bogdan First of all thank you for your time and thank you for trying to help

In the beginning, the site on which the Dashboard is located is on a different server than the child site, but the Dashboard shares with the child only that it is a subdomain from the child site domain.

All sites use DNS and Cloudflare proxy .

It is worth noting that at first, when I encountered the problem, I immediately disabled the Cloudflare proxy. I thought it was the cause, but it turned out that the problem was not from him.

According to the solution you mentioned:

The solution would be to contact the host and ask it to fix its certificate.

For days, the support tickets have not stopped with the company, which is RundCloud, regarding this problem, and they repeatedly assured me that there are no problems on their part regarding SSL and that everything is fine, but today I reinstalled the SSL certificate on the Dashboard website. What is worth mentioning is that In a simple development in the case, it is that when Verify SSL certificate (optional) is disabled and the connection is attempted, the experiment succeeds, but I cannot add.

I told them that this information was mentioned by you and that the problem is specifically in the cURL version:

In this specific case, I think that the problem comes from the cURL Version on your dashboard or its configuration

Their answer was that the server had the latest version installed.

Another site was added, and the addition was excellent and smooth, and I did not experience any problems
The problem only appeared on this child’s website specifically!
Now what should I do?
If there is a specific matter or problem that you see as real in the components of the server itself, tell me about it and I will transfer it as it is to RundCloud in the hope that the problem will be solved.
If there is something I should do, I am on the server and I am not a very expert, my knowledge is average, let me know.

In conclusion, I actually bought and came to MainWP to make it easier for me to manage my clients’ websites
But now, in fact, I am very afraid to rely on him, lest he encounter such a problem on one of my clients’ sites and I will not find a solution for it.

Guys, I bought MainWP PRO a few days ago. In fact, I haven’t tried it yet for a few days, and all I’m busy with is searching for a solution to this problem.

Thank you for looking into the potential problem with SSL and cURL versions with the hosting support.

We will now take a closer look at your setup, and I’ve messaged you on HelpScout about the next steps.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.