Error when attempting admin login to child site

I am getting this error.
Sorry, there was an error. Please be sure JavaScript and Cookies are enabled in your browser and try again.
This site has a modified login url that I created with the iThemes Security plugin prior to moving to MainWP

My other sites work fine.

Hey @davidcuff

Welcome to the MainWP Community.

Can you please elaborate on how exactly you are trying to log in to the child site? Directly using the modified login URL, or in some way through MainWP Dashboard?

Please attach a screenshot if possible so we can have a better understanding of the context of the error message.

Through the MainWP Dashboard.
Here is a loom video of the process: Loom | Free Screen & Video Recording Software | Loom

@davidcuff ,

Thanks for the screen recording.

Just to be sure that this is indeed due to the custom login URL, can you please temporarily revert it to the default within iThemes Security settings and see if that helps?

I can not… There are 80k visits a day and hackers overload the site by trying to login with bots.

Is there a way to add the unique login URL to the dashboard so it works?
We use iThemes Security which has renamed the wp-admin to a new url

It’s not possible to manually define the login URL. However, in our testing, changing the login URL with various plugins didn’t impact logging into the child sites from the MainWP Dashboard.

Do you know if the login URL was changed after the site was added to MainWP Dashboard? If so, can you try re-adding it and see if that helps?

It was not added after. It has been changed for over 4 years now…
The first time I tried after adding it to the console it gave that error.

Unfortunately, we cannot reproduce this issue.

When we changed the login URL with iThemes security, we could still log in through MainWP Dashboard.

We must conclude that the issue is caused by something else, or perhaps a combination of factors of which iThemes is only one of them.

Considering you cannot change the login URL on this live site, and I assume you also cannot temporarily disable other non-MainWP plugins, perhaps you can try setting up a staging site, add it to the Dashboard, and see if the issue with the staging site is resolved by either renaming the login URL or by disabling some other set of plugins.

Thank you Borjan for all or effort on this issues.
It is a bit of a show stopper as this client and server are one of our largest clients.

New information: some of the other subdomains are also having the issue now.
Some on this server work and some don’t with the same error as posted before.
The sites update and refresh but the login does not work.

I am trying to migrate all of our 105 sites to MainWP but this is making that transition difficult.
This site is over 4gb in size so I am hoping to fix the issue without copying and replacating it.

This site and all subdomains are in Cloudflare Business edition.
I have whitelisted my IP address in the firewall. I will try whitelisting my origin ip address where mainwp console
is hosted.

Whilelisting origen server for MainWP console did not solve the issue.

Do all of the site that are experiencing issues have their Login URL changed with iThemes?

Please check if you are using any other Cloudflare features other than WAF and if you can whitelist the Dashboard’s IP there as well.

New information:
After failing to connect (login as admin), if I click on the entire URL code and click enter it works…
I found this out while trying to create a HAR file from “Inspect/Network/Record” because it opens a new window and I had to start the recording again.


I’ve deleted your second post for security reasons.

This is a rather unusual issue. However, due to the fact that the Dashboard appears to be sending the proper and required authentication details to the child site, the issue still appears to be caused by something on the child site.

It may be a combination of login URL change in iThemes and some other plugin. And considering other subdomains are starting to experience the same issue, Cloudflare may also be a factor.

Since we cannot reproduce the issue and we don’t have other reports of it, the only recourse right now is to try to isolate the factors in your specific setup.

If possible, try temporarily disabling login URL change, all plugins except for MainWP Child, Cloudflare and any other server-side security present on that domain, etc…

Unless we can narrow it down more, we are sadly not in a great position to help.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.