Featured image is not being sent to child sites

It worked fine for long time. But now suddenly - not sure if I updated something - the featured images are often not being sent to the child sites. It varies, it seems. One site does not receive these at all. I am working with the latest version of Wordpress and MainWp.

Any idea why that could be? Someone with similar experiences?

Hi @luftikus143,

Did you install some security plugins on your dashboard recently?

No, nothing I am aware of.

Is there anything on the server side? Some security rule or SSL verification error?

Problems like this can happen if a child site can’t reach to the dashboard site.
When publishing a content, the child site will reach to the dashboard to download the image, but if some security rule blocks it or SSL verification fails, the image can’t be downloaded and it fails.

Hmm, not that I am aware of. It’s interesting to see that the three child-sites I have - they reside all on the same hosting provider - do differ. One of the three »accepts« the image. Strange.

Can you please post the community system report from your MainWP Dashboard for review? The report is located in your Dashboard under Status → Server, on the top right of the page.

Be sure to use the button like the one below; this button hides all your private information:


Pressing the button auto-copies the report to your clipboard then just paste it in a reply here.

Here you go, although partially in german:

### Server Info                    Required                                               Detected                                     Status   ###

MainWP Dashboard                   
MainWP Dashboard Version                                                                             Bestanden   
MainWP Upload Directory            Writable                                               Writable                                     Bestanden   
MainWP Custom Dashboard Extension  4.0                                                    API License Active                           Bestanden   
WordPress Version                  >=3.6                                                  5.8.1                                        Bestanden   
WordPress Memory Limit             >=64M                                                  256M                                         Bestanden   
MultiSite Disabled                 =true                                                  true                                         Bestanden   
Dateisystem-Methode                = direct                                               ftpsockets                                   Warnung     
PHP Version                        >=7.0                                                  7.4.21-he.0                                  Bestanden   
PHP Safe Mode Disabled             =true                                                  true                                         Bestanden   
PHP Max Execution Time             >=30 seconds                                           30                                           Bestanden   
PHP Max Input Time                 >=30 seconds                                           60                                           Bestanden   
PHP Memory Limit                   >=128M                                                 256M                                         Bestanden   
PCRE Backtracking Limit            >=10000                                                1000000                                      Bestanden   
PHP Upload Max Filesize            >=2M                                                   32M                                          Bestanden   
PHP Post Max Size                  >=2M                                                   32M                                          Bestanden   
SSL Extension Enabled              =true                                                  true                                         Bestanden   
SSL Warnings                       = empty                                                                                             Bestanden   
cURL Extension Enabled             =true                                                  true                                         Bestanden   
cURL Timeout                       >=300 seconds                                          60                                           Warnung     
cURL Version                       >=7.18.1                                               7.64.0                                       Bestanden   
cURL SSL Version                   >=OpenSSL/1.1.0                                        OpenSSL/1.1.1d                               Bestanden   
PHP Allow URL fopen                JA                                                     
PHP unterstützt Exif               JA ( V7.4.)                                            
PHP unterstützt IPTC               JA                                                     
PHP unterstützt XML                JA                                                     
PHP Deaktivierte Funktionen        syslog,                                                
PHP Geladene Erweiterungen         Core, PDFlib, PDO, Phar, Reflection, SPL, SimpleXML, apache2handler, bcmath, bz2, calendar, ctype, curl, date, dba, dom, exif, fileinfo, filter, ftp, gd, geoip, gettext, hash, iconv, imap, intl, ionCube Loader, json, ldap, libxml, mbstring, mysqli, mysqlnd, openssl, pcre, pdo_mysql, pdo_sqlite, posix, pspell, session, shmop, soap, sockets, sqlite3, standard, sysvmsg, sysvsem, sysvshm, tidy, timezonedb, tokenizer, xml, xmlreader, xmlrpc, xmlwriter, xsl, zip, zlib
MySQL Version                      >=5.0                                                  5.7.35-38-log                                Bestanden   
MySQL-Modus                        NO_ENGINE_SUBSTITUTION                                 
MySQL Client Verschlüsselung       utf8                                                   
Server Info                        
Server-Software                    Apache                                                 
Betriebssystem                     Linux                                                  
Architektur                        64		 bit                                               
Server-Protokoll                   HTTP/1.0                                               
HTTPS                              AUS                                                    
Verbindung zum Server selbst       Response Test O.K.                                     
User Agent                         Mozilla/5.0 (Macintosh; Intel Mac OS X 10_13_6) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/94.0.4606.81 Safari/537.36
Geteway-Schnittstelle              CGI/1.1                                                
Arbeitsspeicherauslastung          39.46 MB                                               
Antwortzeit                        1634121706                                             
Inhalt akzeptieren                 text/html,application/xhtml+xml,application/xml;q=0.9,image/avif,image/webp,image/apng,*/*;q=0.8,application/signed-exchange;v=b3;q=0.9
Zeichensatz des Inhalts            n. a.                                                  
Anzahl Child-Websites              4                                                      
WP-Cron benutzen                   Nein                                                   
Für Shared Hosting oder große Netzwerke optimierenNein                                                   
Automatische tägliche AktualisierungInstall trusted updates                                
Aufgegebene Plugins/Themes-Toleranz                                                       
Maximale Anzahl der Beiträge, die zurückgegeben werden sollen50                                                     
Maximale Anzahl der Seiten, die zurückgegeben werden sollen                                                       
Vorrangiges Backup-System          Standard MainWP Backups                                
Maximale gleichzeitige Anfragen    4                                                      
Minimale Verzögerung zwischen Anfragen200                                                    
Maximale gleichzeitige Anfragen pro IP1                                                      
Minimale Verzögerung zwischen Anfragen zu derselben IP1000                                                   
Maximale gleichzeitige Synchronisierungs-Anfragen                                                       
Minimale gleichzeitige Installieren/Aktualisieren-Anfragen                                                       
Active Plugins                     
Add Featured Image Custom Link     1.1.0                                                  Aktiviert                                    
Akismet Anti-Spam                  4.2.1                                                  Inaktiv                                      
Hello Dolly                        1.7.2                                                  Inaktiv                                      
MainWP Dashboard                                                         Aktiviert                                    

@luftikus143 Na!

That’s quite ok… I can translate & really only interested in the numbers and if things are passing.

I am pretty sure this could be and is the issue. Would you be able to add this line to your WP-config.php file?

define(‘FS_METHOD’, ‘direct’);

In short - when you upload a file via PHP it is the owner. Since you are using ftpsockets to access the file system PHP is complaining that it’s not the owner of the file.

This setting is explained a bit more in detail here on the excepted answer:

Thanks for further looking into this. But unfortunately, nothing has changed. I added the line in the MainWP and in the child sites - but same thing: The image is not being displayed/transferred. Hmmm… strange!

@luftikus143 Is the variable change reflected in the System Reports?

Ah no, it didn’t. Changed the file again (from define(‘FS_METHOD’, ‘ftpsockets’); to define(‘FS_METHOD’, ‘direct’);)… but still not.
Does this need to be changed in MainWP and the Child Sites?

@luftikus143 Possibly both just to be sure. This is actually the first time I saw that not set correctly on a ticket. This might be something that your Host is controlling directly.

Ho, yes! Very nice indeed! Thanks so much!!

However it says now on the child site: » This site may not connect to your dashboard or may have other issues. Check your [MainWP server information page].«

Hmmm Can you disable the Child Plugin and re-enable it? I am not seeing anything else wrong on your MainWP System Report. What does the System Report on the Child Site report - anything say " Warnung "?

Disabled and reenabled - but same message appears.
How can I see the System Report of the Child Site? The tabs »Server information« and »Connection details« don’t show anything…

@luftikus143 There should be another tab to the left of that that says Server information. If it’s not there you have it hidden via the MainWP Dashboard branding settings.

Make sure everything says Pass or good & that your PHP version is <=7.4

You may also open a full Support - MainWP WordPress Management ticket so we can connect and look things over.

I guess this has nothing to do with the current problem. But the MainWP complains:

Configuration issue detected : MainWP has no write privileges to the uploads directory. Because of this some of the functionality might not work.

What is the correct setting?

Yes, I thought so… But nothing happens when I click on that tab… The page stays white…


You may run this tool that I built in order to clear your Child Site DB of ALL MainWP Child Plugin data as if it was fresh. Remove after use for security reasons. This will at least rule that out.


  1. Download the Plugin .Zip
  2. Install like any other Plugin
  3. Active the plugin. It will automatically run and deactivate itself.
  4. Delete the plugin after use by clicking the delete button on the plugin ( there is no Database entries )

Hi Keith, thanks for all the support. I did upload and run the script on one of the sites. It works there. But it works correctly on the other sites too, without uploading the plugin.
I meanwhile did changes on the server side to the folder access rights (changing the owner name)… which did change something for other things that didn’t work.
So perhaps this was the fault of everything. Not sure.
Hope this helps somebody else having the same or similar problems.
Many thanks!!

1 Like