Google Analytics Extension error message

Getting the following error on Sign in With Google account.

Not Acceptable!

An appropriate representation of the requested resource could not be found on this server. This error was generated by Mod_Security.

On the Google 0Auth consent screen, selected External.

MainWP is installed on a subdomain i.e.

Could running MainWP on a subdomain be the problem?

The web hosting company is BlueHost.
Anyone experience any problems with Google Analytics Extension and BlueHost?

Does one have to verify the domain in Google Webmaster Central i.e.

It appears that the instructions are out of date.

Running MainWP on a subdomain shouldn’t effect it’s functionality.
You must verify before making the keys. GA has changed the work flow slightly. I believe it’s around step 14.

1 Like

Verified the domain, then created keys and still get the same error.
Could it be a problem with BlueHost shared hosting account?

Contacted BlueHost support and found out that their firewall had a couple of entries blocking the connection from Google which is now being allowed to pass. Finally got a Connected status.

The problem now is that the extension is not showing the analytics data from Google. Using the Google Analytics API which shows 3 requests and 0% errors on the Google side. Google also offers the Google Analytics Reporting API and Google Analytics Data API. Why is no data being sent from Google to MainWP Google Analytics Extension? Am I using the wrong API?

1 Like

Found the problem. Had to go into into Sites > Manage Sites, then in the right-most column select the ellipses button then select Edit Site. Under Google Analytics account property, select the website property URL in the drop-down.

1 Like

@atteast Awesome! I am glad that you were able to track down what the cause was. Thanks for keeping us updated as well.

Let us know if there is anything we can help with.

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.