Hosting company blocked access to xmlrpc, MainWP cant connect anymore

Many of the sites I managed are hosted at an hosting company that decided to block all WordPress xmlrpc traffic, unless IP address is whitelisted. They whitelisted Jetpack and it works fine. I also whitelisted my MainWP dashboard,
When I try to add a new site on this hosting company, I get

This site can not be reached! Please use the Test Connection feature and see if the positive response will be returned. For additional help, contact the MainWP Support

If I use “Test Connection”, I get

Connection test failed.
Error message: Failed to connect to 2001:1600:4:b:1a66:daff:fe5c:a068: Network is unreachable

I’ve tried to reconnect to an existing site, and I get the message:

HTTP error - Connection timed out after 10005 milliseconds

I also tried renaming the xmlrcp.php file using an extension, but this doesnt work for me.

How does MainWP connect to sites? I didnt see anything in the logs?

I didn’t ask the hosting company yet, I try to get as much info as I can before contacting them.


I have xmlrpc blocked on all of my sites without issue. I would check your logs because they (your host) has blocked something else that they have not told you. Go ahead an post your community system report too since that will help. My guess is that curl is blocked.


I have xmlrpc blocked on all of my sites without issue

Thanks for the info!
After my call with the support all the managed sites with this hosting company were misteriously able to connect again.

I couldn’t check if curl was disabled when I couldn’t connect, but I’ll check if it happens again.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.