HTTP error: No route to host

A couple of my sites got disconnected, with error message “HTTP error - Failed to connect to [domain.com] port 80 after 2949 ms: No route to host.” All the disconnected sites have this error, except with a different ms value. This happened out of nowhere, and we didn’t do any changes in our websites. Contacted our host, and they said that the “port 80” mentioned on the error is working fine.

Any fixes for this? Thanks.

Hey @jeromeiph2

Are the child sites affected by this error all on the same hosting provider or different ones?

Can you try temporarily disabling any security rules you might have on the child sites:

  1. Do you use some security plugins on your child site? If yes, can you try to temporarily disable them and see if that helps?

  2. Do you use Cloudflare or any other cloud proxy firewall? If yes, can you try to whitelist your Dashboard IP or temporarily disable it to see if that helps?

  3. If none of the above helps, can you please contact your host support and have them check server Firewall logs and see if there are any records about blocked requests from your dashboard?

Hi @bojan, thanks for the reply.

Yes, they are all from the same hosting provider.

  1. I’ve tried disabling the security plugins but I still can’t connect.

  2. The sites concerned are not using Cloudflare or any proxy firewall.

  3. I’ve contacted support and according to them they didn’t find any blocked requests on Firewall logs. They have also whitelisted possible mod security rules but the issue is still present

I’m still in touch with support with the issue. Please advise as to other possible steps. Thanks.

Thanks for the update.

Can you ask the support to specifically whitelist the Dashboard’s IP address and see if that helps?

And it also may be useful to contact support where your Dashboard is hosted and have them run the tracert command towards the affected child site so that we can see where exactly the connection is breaking.

Hi, thanks for the reply.

I have tried whitelisting the dashboard IP but it still did not work. Support also tried checking firewall logs while I update but they still were not able to find anything wrong.

I have yet to try disabling all security rules while I reconnect, so I will do that. In the meantime, any advice as to other fixes available?

Thanks.

Also, I forgot to ask, the dashboard IP is the one that can be found in Info → Server → Server IP, right? I’m seeing something labeled “Remote Address” with a string of numbers that look like an IP address. Just want to make sure that’s not it.

Thanks.

Let’s see if disabling other security rules helps. The error you are receiving certainly seems like a networking issue.

The “Remote address” is the IP of the device from which you are accessing the Dashboard, so basically, the IP of your PC or a phone. The IP address of the Dashboard is “Server IP”.

Hi @bojan,

Thanks for the reply.

Unfortunately, disabling security rules doesn’t seem to work. I still get the same error.

Just yesterday we changed the site where we have our MainWP dashboard. Our sites with the “No route to host” error before were unable to connect to the new dashboard and showed the same error.

Do you guys have any other recommended fixes?

If we’re unable to have this fixed, might just leave it as it is for now. I’ve encountered some errors in MainWP that solved itself. Maybe this’ll be the case after some time.

Considering you are getting the same error message for that site even after moving your MainWP Dashboard, strongly indicates that the issue is a security rule present on the child site.

At this point, perhaps you could try contacting the hosting support where the Dashboard is located, and ask them to run tracert command towards the affected child site.
And then contact the hosting support of the child site and present them with the tracert results so that they could provide some insight into why the connection is breaking at that particular network hop.