IP addresses for MainWP

I have a website that won’t connect.

When I do a test, it shows success: Connection Test

But that’s not my IP address OR the IP address of my MainWP dashboard. I can send you those in a private message.

Where is it getting that IP?

My host is saying that the IP address was blocked as a result of unsuccessful email login attempts. Multiple failed login attempts were made yesterday for the following email accounts:

[email protected]
[email protected]
[email protected]
[email protected]

I have nothing to do with any of those accounts or those websites.


I’m not actually sure how to send you those in a private message. I thought I could do a new message and mark it private, but don’t see how to do that. Please let me know how to send this information to you. Thanks!

Okay, so the IP address in question is the one where the SITE is located.

That doesn’t make any sense. I went back to A2 (the host) and will see what they say.

Sorry about the confusion!

Thanks for the update, and let us know how it goes.

A couple of things to remember since MainWP is self-hosted, the plugin does not try to connect to the MainWP site when reaching your Child sites. So our IP addresses wouldn’t help you there.

Also, your MainWP Dashboard does not try to “login” to your sites, so it wouldn’t be using random emails. Your Dashboard and Child sites communicate through OpenSSL. If you are curious and want to dig into that more, we have a Help doc - MainWP Connection Security - MainWP Documentation

Again let us know how it goes with A2 and how we can help.

1 Like

The only IP address that should matter to the host is the IP address of my MainWP parent installation, right? I’ve asked them to check that several times and every time, they say there are no issues. So I’m not sure what else to try to get this site to reconnect. It’s been working for years, but now in the past few weeks has not worked.

This is the error I’m receiving:
Error detected: Connection Failed. We suspect that Imunify360, a security layer added by your host, is causing this problem. Please contact your host to whitelist your Dashboard IP in their system. If you need help determining your MainWP Dashboard site IP address, check with your hosting provider.
Click here to see response from the child site.

And where it says “click here” - that shows this HTML. I pasted it in a viewer so I could see what it said: Response

I asked them to check the IP address again, but I’ve been going back and forth with them since June 1, so I’m not super hopeful :frowning:

Unfortunately, it does sound like A2 support is giving you the runaround. Imunify360 is a security suite we have noticed more hosts putting on their sites. and blocking requests, so we added the extra message. You can generally tell by the “wsidchk” text in your response.

They should be able to white-list your Dashboards IP to pass through Imunify360, but that is really on their side and not much we can do from this end.

Another option will be if you are using Cloudflare to try to change the settings as listed in the
Imunify360 blog: Using Cloudflare “Cache Everything” with Imunify360

I apologize I don’t have a better response for you on that.

edit: A Cloudflare link mentioning A2 is using Imunify360

Super side note: I was looking into going to Recurring Revenue Retreat this year and enjoyed your blog post on it. :smile:


Runaround indeed! They kept saying there were no blocks but then finally whitelisted it “temporarily.” The site connected and I asked if they can keep it whitelisted, so we’ll see.

Glad you liked the post! I interviewed Kristina Romero on my podcast (not aired yet) and she shared her coupon code for listeners in case you end up going and want to use it! WPCMPEEPS for $150 off. Or maybe you’d be going to sponsor? It was interesting that the sponsors each got to give a short presentation in between the main speakers.


I’m glad they sort of got that sorted for you.

For the Retreat, I would be going as a student, not a sponsor so the coupon is super helpful :slight_smile:


Excellent! I’m not able to go this year - it would have been great to meet in person. Maybe sometime in the future!


This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.