MainWP WP 4.2 Extensions API Licensing

Testing the 4.2 beta plugins, I think I was a little too fast deleting the Extensions API key. When I try to get my new key I see it’s not available yet (and I see the warning in the instructions, that I forgot to read before :see_no_evil: ).

Can I just wait until the functionality will be available? I don’t see my old key listed…

What’s the planning of this API update?

Same here - upgraded and found the new API key, used it and a few extensions activated, others didn’t as it said API not valid. Checked my account - Downloads section and a lot of extensions are now missing as though they are not included in my Pro account.

tried old key in the extensions that couldn’t be activated and it said I had not purchased them…

There was an API key now when I just checked, but indeed it’s only for a small list of extensions, not all. I guess they are still working on it to migrate the other extensions to the new method.

I guess so, Tried downgrading the MainWP Dashboard, but the other extensions are still showing as not purchased, will wait a while to see what happens

I just received an email that my order was complete including a bill (probably a mistake, so I’ll check that with the MainWP team) and it had a much longer list of extensions, so I’ve tried to activate all the extensions again and now it worked.

Hey guys, it’s still a work in progress, but since you already hit that button, I manually updated your accounts, so you should be good to go now.

1 Like

Amazing, thanks Bogdan.
Just activated all the other extensions without issue. Thanks

2 Likes

I am also not able to access the extensions. Please fix ASAP!

It should be fixed for you now.

I’m having the same problem. I appreciate if you can help me.
https://drive.google.com/uc?id=1bgy8EjMRzpSpSBldDIB927yFnsvDb1E4

Hi Arthur,

I checked your account and everything seems to be set correctly on our side.

Can you please try to do the following:

  1. Go to the MainWP > Settings > Tools page
  2. Click the Delete extensions API Activation data button
  3. Go back to the MainWP > Extensions page and try to validate your API again?

If that fails, please open a helpdesk ticket so we can check why this happens for you.

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.