Site filter "PHP < 7.0" doesn't work correctly

I just noticed a Sites filter, that I didn’t knew yet “PHP < 7.0”.

But I think this filter has changed without changing the label, because it shows me sites with PHP 7.4 (and probably lower). In the file mainwp/class/class-mainwp-manage-sites-list-table.php I see the status is still called phpver7, while it tests for 8.0.

Besides this bug it would be nice if we can adjust this filter to <8.1 or <8.2 etc.

Hey @josklever

Thanks for reporting this to us.

I’ve managed to reproduce the issue, and I’ve passed it along to the development team.

It will be fixed in the next release of MainWP.

1 Like