Unable to add staging site - MainWP can't connect thru the basic auth

I have a staging site that I’m trying to add. I haven’t had this issue with the other 12 sites I manage. All plugins, theme and core updates have been made to MainWP and this staging site.

Staging site has a basic auth on it to access. This username/password has been entered into the optional settings, the plugin is active, I’m using the unique security ID and MainWP is still unable to get around the basic authorization.

Test connection gives a 401 error, but all my staging sites do because of the basic auth.

What else can I try?

Hi @dazzledev

Welcome to the MainWP community.

Is the basic auth set up on that child site in the same way as on the other child sites?

Can you temporarily try removing basic auth and see if you are able to add the child site then?

I’m not sure why I didn’t think of that. It worked and the site was added to my dashboard.

I added the basic auth back to the site and tried to sync and it will not sync. And yes, every site is set up the same way.

1 Like

Well, it appears that the issue was related to basic auth.

Can you now try adding the auth username/password for that child site and see if the sync works? You can do that under Sites > Manage Sites > Individual Child site overview > Edit, and then look for Advanced Settings section.

Hi Abby,

You said that other sites are set the same way. I assume that other sites are working correctly. Just this one has the problem connecting with the HTTP Basic Auth set.

If I am right, this is very strange.

The only thing that comes to my mind is that maybe some special character is used in the HTTP Password that could get converted into HTTP request.

Can you try to reset HTTP Username and HTTP Password on the site and see if that helps?

Please correct me if I misunderstood something here.

1 Like


It was a slash in the basic auth password causing the issue.

Thanks for your help, Bogdan!

You can close the ticket.


This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.