Updating plugins in child sites

Hi,
I have a problem updating the plugins on my child sites. An error message appears.
“Main Wp child plugin not detected or could not be reached. Ensure that the Main Wp child plugin is installed and activated on the child site, and there are no security rules blocking requests”
What is strange is that the update is done well on my child sites despite this message and when I sync again Main WP updates have been taken into account.
I’m using Secupress and I’ve already tested deactivating it. I’m also using Cloudflare and I’ve removed the settings but I haven’t tried changing the DNS.
Do you know where this error is coming from?
Thanks in advance

Hey @sivhadesign

Welcome to the MainWP community!

Based on this, syncing the site works without any issues, only updating produces this error?
Does other functionality like managing posts/pages/users via the Dashboard work fine?

Can you please post the community system report from your MainWP Dashboard for review? The report is located in your Dashboard under Info → Server, on the top right of the page.

Be sure to use the button like the one below; this button hides all your private information:

image

Pressing the button auto-copies the report to your clipboard then just paste it in a reply here.

Hi,

Thanks for your reply.
Yes, the synchronization of the sites works without problem, it is the update indeed.
I haven’t tested the other features.
I tried to put the community system report from my MainWP Dashboard but it said “An error occurred: Sorry, new users can only put 2 links in a post.” when I tried to send my message.
I send you by mail.

I have just tried to install a theme and I have the same problem: the theme is installed on the child site but on the Main WP it says error while installing.
but when I activate it with MainWP I get a success message

However, if I install an extension or a theme as a zip file, it doesn’t work at all. I have to install from worpress.org

Hi @sivhadesign

I received your system reports in the ticket you opened previously, thank you.

Could you try temporarily deactivating all non-MainWP plugins on the child site and running a plugin update via the MainWP Dashboard?
Also, do you experience any issues when updating plugins directly on the WP Admin of the child site?

What error message do you get when you try to install it via ZIP upload?

I don’t really understand, if I leave only the mainWP child plugin active on my child site, which plugin will I be able to update?

When I update plugins directly in the child site’s WP Admin, everything works fine.

The error message I get when I try to install a plugin via the ZIP download is as follows: Error while installing

Thanks for the update.

Let’s continue the troubleshooting in the ticket you have previously opened.

I will update the community here when we find the solution.

2 Likes