Warning: openssl_pkey_export():

Is there any update on this issue yet. It is ultimately an issue with Main WP. There has to be a solution to the issue. I have been asking for over 4 days now.

Having had to purchase a new M3 mac, and uploaded fresh version of Main WP, I get these issues.

Warning : openssl_pkey_export(): Cannot get key from parameter 1 in /Users/stevennicholls/Local Sites/salientsync/app/public/wp-content/plugins/mainwp/pages/page-mainwp-server-information-handler.php on line 223

MainWP has detected that the OpenSSL.cnf file is not configured properly. It is required to configure this so you can start connecting your child sites. Please, click here to configure it!

If your MainWP Dashboard has no issues with connecting child sites, you can dismiss this warning by clicking the Error Fixed button.

There has to be a resolution to this issue. I have tried different PHP versions, with no success. Somebody must know what the answer to the problem is.

Please can someone advise.

Hey @Steven

Welcome to the MainWP community!

Did you install MainWP on a local or a web host?

Can you please post the community system report from your MainWP Dashboard for review? The report is located in your Dashboard under Info → Server, on the top right of the page.

Be sure to use the button like the one below; this button hides all your private information:

image

Pressing the button auto-copies the report to your clipboard then just paste it in a reply here.

for some reason the copy system report download system report is not working.

This is an error I get from the server page within mainwp

Warning: openssl_pkey_export(): Cannot get key from parameter 1 in /Users/stevennicholls/Local Sites/salientsync/app/public/wp-content/plugins/mainwp/pages/page-mainwp-server-information-handler.php on line 223

Fatal error: Uncaught TypeError: openssl_pkey_get_details(): Argument #1 ($key) must be of type OpenSSLAsymmetricKey, false given in /Users/stevennicholls/Local Sites/salientsync/app/public/wp-content/plugins/mainwp/pages/page-mainwp-server-information-handler.php:263 Stack trace: #0 /Users/stevennicholls/Local Sites/salientsync/app/public/wp-content/plugins/mainwp/pages/page-mainwp-server-information-handler.php(263): openssl_pkey_get_details(false) #1 /Users/stevennicholls/Local Sites/salientsync/app/public/wp-content/plugins/mainwp/pages/page-mainwp-server-information.php(637): MainWP\Dashboard\MainWP_Server_Information_Handler::get_openssl_working_status() #2 /Users/stevennicholls/Local Sites/salientsync/app/public/wp-content/plugins/mainwp/pages/page-mainwp-server-information.php(479): MainWP\Dashboard\MainWP_Server_Information::render_php_check_tbody() #3 /Users/stevennicholls/Local Sites/salientsync/app/public/wp-includes/class-wp-hook.php(324): MainWP\Dashboard\MainWP_Server_Information::render(‘’) #4 /Users/stevennicholls/Local Sites/salientsync/app/public/wp-includes/class-wp-hook.php(348): WP_Hook->apply_filters(‘’, Array) #5 /Users/stevennicholls/Local Sites/salientsync/app/public/wp-includes/plugin.php(517): WP_Hook->do_action(Array) #6 /Users/stevennicholls/Local Sites/salientsync/app/public/wp-admin/admin.php(259): do_action(‘mainwp_page_Ser…’) #7 {main} thrown in /Users/stevennicholls/Local Sites/salientsync/app/public/wp-content/plugins/mainwp/pages/page-mainwp-server-information-handler.php on line 263

There has been a critical error on this website. Please check your site admin email inbox for instructions.

SSL Warnings = empty error:0E078072:configuration file routines:def_load:no such file error:2006D080:BIO routines:BIO_new_file:no such file error:02001002:system library:fopen:No such file or directory error:0E078072:configuration file routines:def_load:no such file error:2006D080:BIO routines:BIO_new_file:no such file error:02001002:system library:fopen:No such file or directory
cURL Extension Enabled =true true
cURL Timeout >=300 seconds 60
cURL Version >=7.29.0 8.4.0
OpenSSL Version >=OpenSSL/1.1.0 (SecureTransport) LibreSSL/3.3.6

Hey @Steven

Thank you for the additional information.

Just a friendly reminder that you have an open private ticket with us, and that we are waiting on your reply since March 22nd.

Let me try addressing the potential culprit for the issue you’re experiencing.

Based on the information from your last message, the culprit is almost certainly related to the LibreSSL library.

We haven’t had the chance to test OpenSSL alternatives, so our suggestion would be to update your setup to use OpenSSL, or to use a different localhost solution.

Another option would be to use our built-in alternative to OpenSSL, which is PHPSecLib. More information about PHPSecLib is available here: Custom Signature Algorithm and PHPSecLib as alternative to OpenSSL - MainWP Documentation

We haven’t had other reports of this nature, so with all that in mind, we must conclude that this is an edge case resulting primarily from your non-standard environment.

1 Like

Hi @Steven,

Just to add some more details.

I don’t have Mac, but tried on Windows OS, after installing LocalWP and setting up site, by default my setup came with OpenSSL, not LibreSSL (this could be some OS thing), I also got the OpenSSL.cnf file misconfiguration error, the same one as you did.

But right after switching to PHPSecLib as @Bojan suggested:

MainWP > Settings > Advanced Settings

error is gone and I could add sites:

1 Like