When creating a staging site, it stops with notice: "Array"

I’ve just tried to create a staging site for one of my child sites, because on Facebook someone reported that it didn’t work. After installing the WP Staging plugin on the child I’ve clicked “Create New”, gave the site a name and clicked “Create Staging Site”. After that the process should start but only the text “Array” is shown and nothing seems to happen.

A few tables have been copied, but no files (yet).

I’m using MainWP 4.0.x dashboard and child and related extensions.

The staging copies are shown in the overview, but if I try to remove them again nothing happens and the items are missing.

I also have this issue. Identical. The MainWP just returns the word Array when trying to create a staging site. After waiting 20 minutes, I still didn’t see any evidence of files being copied or anything. When I log into the child site and go to the staging plugin interface, it shows the staging site there labeled as “broken or incomplete”. If you hit the update or create new from within the plugin, it warns you that an operation is currently running - but it never finishes.

Also - creating one directly from the plugin on the child site worked and only took about 5 minutes.

Hi guys, thanks for reporting this problem.

I was able to reproduce is so I will have our dev team check this as soon as possible. As soon as I get more if from them, I will let you know.



Hi guys, the dev team fixed the problem and the fix will be included in the next official release.

In the meantime, you can grab the pre-release versions from here:

If you are using MainWP Child 4.1-beta2, there is no need to update the child plugin. MainWP Child should be replaced with the version from above, only if you are using



Thanks for the quick fix! I hope that I can test it tomorrow.


I’ve tested this on one site. It seems to work. I have some observations (I’m a new user to this particular extension btw).

  • Creation is flawless.

  • When the child site is automatically created for a staging site, the only way to find it is by filtering the groups to show child sites only - if you show all sites, they’re not in the list (I kinda expected them in the all sites list).

  • If you use the extension to delete a staging site, all of the files are left behind and the staging site isn’t removed from the child sites list (seems this is wrong).

(edited for clarity)

Each “Staging Site” automatically gets put into a “Staging Site” group. Simply selecting that group will display all your Staging Sites you have created within your Child Site Network.

If you use the extension to delete a staging site, all of the files are left behind and the staging site isn’t removed from the child sites list (seems this is wrong).

This will need to be looked into. Can you please open a new topic for the issues that you are having or open a private Support - MainWP WordPress Management ticket so that we may help you.

1 Like

Thanks Keith. I figured out how to see the staging sites, I just didn’t have the expectation that the staging group would behave differently than any other groups I’ve created in that it doesn’t show with using the “all groups” filter. Thanks!

1 Like

I was able to test it just now. The creation of the staging site is working correctly now, but on removal the files remain at the server creating a vulnerability, because the WP installation can be executed by anyone, getting control of that instance and probably also of the main site. Of course I’ve removed them manually.

The staging sites also don’t get removed from the MainWP dashboard sites list. Still visible in the Staging Sites group.

Thanks for the update.

I will have the dev team check the removal process.

I submitted a private support ticket for this yesterday. Thanks for confirming it wasn’t just me.


Hi all,

I am sending new versions, please find the new extension update here:

If you are using MainWP Dashboard 4.1-beta2 version, please update to this:

Hi Bogdan,

I’ve just tested the new version of the Staging extension and the issues are solved. Thanks!


This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.